CVE-2025-25183 vLLM using built-in hash() from Python 3.12 leads to predictable hash collisions in vLLM prefix cache

Low 2.6 Published Updated

Attackers can exploit predictable hash collisions in vLLM's prefix cache to serve incorrect cached responses, potentially leaking data or causing logic errors.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2025-25183?

CVE-2025-25183 is a low-severity vulnerability in Vllm Vllm, published on 7 Feb 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

vLLM is a high-throughput and memory-efficient inference and serving engine for LLMs. Maliciously constructed statements can lead to hash collisions, resulting in cache reuse, which can interfere with subsequent responses and cause unintended behavior. Prefix caching makes use of Python's built-in hash() function. As of Python 3.12, the behavior of hash(None) has changed to be a predictable constant value. This makes it more feasible that someone could try exploit hash collisions. The impact of a collision would be using cache that was generated using different content. Given knowledge of prompts in use and predictable hashing behavior, someone could intentionally populate the cache using a prompt known to collide with another prompt in use. This issue has been addressed in version 0.7.2 and all users are advised to upgrade. There are no known workarounds for this vulnerability.

Weakness: CWE-354

Which versions are affected by CVE-2025-25183?

3 open source packages ship an affected version, including vllm. It affects 1 product.

PackageAffectedFixed in
vllm PyPIAll versions0.7.2
vllm PyPIAll versions0.7.2
vllm PyPIAll versions0.7.2

Products include Vllm Vllm.

How do I fix CVE-2025-25183?

Upgrade vllm to 0.7.2 or later.

Is CVE-2025-25183 being exploited?

There is no known exploitation of CVE-2025-25183 in the wild and no public exploit code.

All Vllm Vllm vulnerabilities

Sources

Also known as GHSA-rm76-4mrf-v9r8, PYSEC-2025-62.

Is CVE-2025-25183 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free