# CVE-2025-25183: vLLM using built-in hash() from Python 3.12 leads to predictable hash collisions in vLLM prefix cache

> Attackers can exploit predictable hash collisions in vLLM's prefix cache to serve incorrect cached responses, potentially leaking data or causing logic errors.

- **Severity:** Low 2.6 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 7 Feb 2025
- **Updated:** 12 Feb 2025
- **Also known as:** GHSA-rm76-4mrf-v9r8, PYSEC-2025-62

## What is CVE-2025-25183?

CVE-2025-25183 is a low-severity vulnerability in Vllm Vllm, published on 7 Feb 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

vLLM is a high-throughput and memory-efficient inference and serving engine for LLMs. Maliciously constructed statements can lead to hash collisions, resulting in cache reuse, which can interfere with subsequent responses and cause unintended behavior. Prefix caching makes use of Python's built-in hash() function. As of Python 3.12, the behavior of hash(None) has changed to be a predictable constant value. This makes it more feasible that someone could try exploit hash collisions. The impact of a collision would be using cache that was generated using different content. Given knowledge of prompts in use and predictable hashing behavior, someone could intentionally populate the cache using a prompt known to collide with another prompt in use. This issue has been addressed in version 0.7.2 and all users are advised to upgrade. There are no known workarounds for this vulnerability.

Weakness: CWE-354 (Improper Validation of Integrity Check Value)

## Which versions are affected by CVE-2025-25183?

3 open source packages ship an affected version, including vllm. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vllm` | PyPI | All versions | 0.7.2 |
| `vllm` | PyPI | All versions | 0.7.2 |
| `vllm` | PyPI | All versions | 0.7.2 |

Products: Vllm Vllm.

## How do I fix CVE-2025-25183?

Upgrade vllm to 0.7.2 or later.

## Is CVE-2025-25183 being exploited?

There is no known exploitation of CVE-2025-25183 in the wild and no public exploit code.

## Other vulnerabilities in Vllm Vllm

- [CVE-2025-32444](https://insights.sbomify.com/CVE-2025-32444/): vLLM Vulnerable to Remote Code Execution via Mooncake Integration (critical 10.0)
- [CVE-2026-22778](https://insights.sbomify.com/CVE-2026-22778/): vLLM leaks a heap address when PIL throws an error (critical 9.8)
- [CVE-2025-47277](https://insights.sbomify.com/CVE-2025-47277/): vLLM Allows Remote Code Execution via PyNcclPipe Communication Service (critical 9.8)
- [CVE-2024-11041](https://insights.sbomify.com/CVE-2024-11041/): Remote Code Execution in vllm-project/vllm (critical 9.8)
- [CVE-2026-48746](https://insights.sbomify.com/CVE-2026-48746/): vLLM: OpenAI auth bypass (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-25183 and fix it if it is affected.

What it is: CVE-2025-25183 is a low-severity vulnerability in Vllm Vllm, published on 7 Feb 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-25183 in the wild and no public exploit code.

Affected packages and fixed versions:
- vllm (PyPI): affected all versions; fixed in 0.7.2
- vllm (PyPI): affected all versions; fixed in 0.7.2
- vllm (PyPI): affected all versions; fixed in 0.7.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-25183/ (Markdown: https://insights.sbomify.com/CVE-2025-25183/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-25183
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-25183
- OSV: https://osv.dev/vulnerability/CVE-2025-25183

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-25183/
Summaries are generated and may contain mistakes; the official description above is the record.
