CVE-2025-25184 Possible Log Injection in Rack::CommonLogger
Attackers can inject CRLF characters into log entries via crafted usernames, corrupting logs or hiding activity in Rack-based Ruby applications.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-25184?
CVE-2025-25184 is a medium-severity vulnerability in rack, published on 12 Feb 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Rack provides an interface for developing web applications in Ruby. Prior to versions 2.2.11, 3.0.12, and 3.1.10, Rack::CommonLogger can be exploited by crafting input that includes newline characters to manipulate log entries. The supplied proof-of-concept demonstrates injecting malicious content into logs. When a user provides the authorization credentials via Rack::Auth::Basic, if success, the username will be put in env['REMOTE_USER'] and later be used by Rack::CommonLogger for logging purposes. The issue occurs when a server intentionally or unintentionally allows a user creation with the username contain CRLF and white space characters, or the server just want to log every login attempts. If an attacker enters a username with CRLF character, the logger will log the malicious username with CRLF characters into the logfile. Attackers can break log formats or insert fraudulent entries, potentially obscuring real activity or injecting malicious data into log files. Versions 2.2.11, 3.0.12, and 3.1.10 contain a fix.
Which versions are affected by CVE-2025-25184?
6 open source packages ship an affected version, including rack. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
rack RubyGems | All versions | 2.2.11 |
rack RubyGems | All versions | 2.2.11 |
rack RubyGems | From 3.0 | 3.0.12 |
rack RubyGems | From 3.0 | 3.0.12 |
rack RubyGems | From 3.1 | 3.1.10 |
rack RubyGems | From 3.1 | 3.1.10 |
Linux distribution packages (4)
pcs Red Hat:enterprise_linux:9::highavailability | All versions | 0:0.11.9-2.el9 |
pcs-snmp Red Hat:enterprise_linux:9::highavailability | All versions | 0:0.11.9-2.el9 |
pcs Red Hat:enterprise_linux:9::resilientstorage | All versions | 0:0.11.9-2.el9 |
pcs-snmp Red Hat:enterprise_linux:9::resilientstorage | All versions | 0:0.11.9-2.el9 |
Products include Rack Rack.
How do I fix CVE-2025-25184?
Upgrade rack to a fixed version for your release line: 2.2.11, 3.0.12 or 3.1.10.
Is CVE-2025-25184 being exploited?
There is no known exploitation of CVE-2025-25184 in the wild and no public exploit code.
Other vulnerabilities in rack
- CVE-2026-34785 Rack: Local file inclusion in `Rack::Static` via URL Prefix Matching
- CVE-2026-34827 Rack: Algorithmic-Complexity DoS in Rack::Multipart::Parser
- CVE-2026-34829 Rack: Denial of Service via Unbounded Multipart File Upload Without Content-Length
- CVE-2026-22860 Rack has a Directory Traversal via Rack:Directory
- CVE-2025-61919 Rack is vulnerable to a memory-exhaustion DoS through unbounded URL-encoded body parsing
Sources
Also known as DEBIAN-CVE-2025-25184, GHSA-7g2v-jj9q-g3rg, MINI-qwwh-jr8r-c36v, MINI-vmwh-xc8q-88cc, RHSA-2025:7085, UBUNTU-CVE-2025-25184.