{"answers":{"affected":"6 open source packages ship an affected version, including net-imap.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-25186 exists.","fix":"Upgrade net-imap to a fixed version for your release line: 0.3.8, 0.4.19 or 0.5.6.","what":"CVE-2025-25186 is a medium-severity denial of service vulnerability in ruby net-imap, published on 10 Feb 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-25186 and fix it if it is affected.\n\nWhat it is: CVE-2025-25186 is a medium-severity denial of service vulnerability in ruby net-imap, published on 10 Feb 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-25186 exists.\n\nAffected packages and fixed versions:\n- net-imap (RubyGems): affected from 0.3.2; fixed in 0.3.8\n- net-imap (RubyGems): affected from 0.3.2; fixed in 0.3.8\n- net-imap (RubyGems): affected from 0.4.0; fixed in 0.4.19\n- net-imap (RubyGems): affected from 0.4.0; fixed in 0.4.19\n- net-imap (RubyGems): affected from 0.5.0; fixed in 0.5.6\n- net-imap (RubyGems): affected from 0.5.0; fixed in 0.5.6\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-25186/ (Markdown: https://insights.sbomify.com/CVE-2025-25186/index.md)","id":"CVE-2025-25186","markdown":"https://insights.sbomify.com/CVE-2025-25186/index.md","name":"CVE-2025-25186","record":{"aliases":["AZL-56555","BELL-CVE-2025-25186","DEBIAN-CVE-2025-25186","GHSA-7fc5-f82f-cx69","MINI-44mx-vwr4-8c9p","OESA-2025-1195","OESA-2025-1196","UBUNTU-CVE-2025-25186"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby IMAP client library","requires_auth":"none","summary":"A malicious IMAP server can cause memory exhaustion and denial of service in the Ruby Net::IMAP client by sending highly compressed uid-set data.","user_interaction":"required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":6.5,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-770","name":"Allocation of Resources Without Limits or Throttling"},{"id":"CWE-409","name":"Improper Handling of Highly Compressed Data (Data Amplification)"},{"id":"CWE-789","name":"Memory Allocation with Excessive Size Value"},{"id":"CWE-405","name":"Asymmetric Resource Consumption (Amplification)"},{"id":"CWE-400","name":"Uncontrolled Resource Consumption"},{"id":"CWE-1287","name":"Improper Validation of Specified Type of Input"}],"description":"Net::IMAP implements Internet Message Access Protocol (IMAP) client functionality in Ruby. Starting in version 0.3.2 and prior to versions 0.3.8, 0.4.19, and 0.5.6, there is a possibility for denial of service by memory exhaustion in `net-imap`'s response parser.  At any time while the client is connected, a malicious server can send  can send highly compressed `uid-set` data which is automatically read by the client's receiver thread. The response parser uses `Range#to_a` to convert the `uid-set` data into arrays of integers, with no limitation on the expanded size of the ranges. Versions 0.3.8, 0.4.19, 0.5.6, and higher fix this issue. Additional details for proper configuration of fixed versions and backward compatibility are available in the GitHub Security Advisory.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Net::IMAP vulnerable to possible DoS by memory exhaustion","id":"CVE-2025-25186","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"denial_of_service","year":"2025"},"n_packages":6,"n_references":4,"next":{"headline":"Cross-site Scripting in Goto Anything allows arbitrary code execution in Joplin","id":"CVE-2025-25187"},"packages":[{"ecosystem":"RubyGems","fixed":["0.3.8"],"introduced":["0.3.2"],"last_affected":[],"package":"net-imap","purl":null,"source":"GHSA-7fc5-f82f-cx69"},{"ecosystem":"RubyGems","fixed":["0.3.8"],"introduced":["0.3.2"],"last_affected":[],"package":"net-imap","purl":"pkg:gem/net-imap","source":"GHSA-7fc5-f82f-cx69"},{"ecosystem":"RubyGems","fixed":["0.4.19"],"introduced":["0.4.0"],"last_affected":[],"package":"net-imap","purl":null,"source":"GHSA-7fc5-f82f-cx69"},{"ecosystem":"RubyGems","fixed":["0.4.19"],"introduced":["0.4.0"],"last_affected":[],"package":"net-imap","purl":"pkg:gem/net-imap","source":"GHSA-7fc5-f82f-cx69"},{"ecosystem":"RubyGems","fixed":["0.5.6"],"introduced":["0.5.0"],"last_affected":[],"package":"net-imap","purl":null,"source":"GHSA-7fc5-f82f-cx69"},{"ecosystem":"RubyGems","fixed":["0.5.6"],"introduced":["0.5.0"],"last_affected":[],"package":"net-imap","purl":"pkg:gem/net-imap","source":"GHSA-7fc5-f82f-cx69"}],"prev":{"headline":"GPT Academic allows arbitary file read by tarfile uncompress within softlink","id":"CVE-2025-25185"},"products":["net-imap"],"published":"2025-02-10","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-02-12","vendors":["ruby"]},"summary":"A malicious IMAP server can cause memory exhaustion and denial of service in the Ruby Net::IMAP client by sending highly compressed uid-set data.","url":"https://insights.sbomify.com/CVE-2025-25186/"}