CVE-2025-25196 OpenFGA Authorization Bypass
Attackers can bypass authorization checks in OpenFGA under specific model and tuple configurations, gaining unauthorized access to protected resources.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-25196?
CVE-2025-25196 is a medium-severity authentication bypass vulnerability in openfga, published on 19 Feb 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
OpenFGA is a high-performance and flexible authorization/permission engine built for developers and inspired by Google Zanzibar. OpenFGA < v1.8.4 (Helm chart < openfga-0.2.22, docker < v.1.8.4) are vulnerable to authorization bypass when certain Check and ListObject calls are executed. Users on OpenFGA v1.8.4 or previous, specifically under the following conditions are affected by this authorization bypass vulnerability: 1. Calling Check API or ListObjects with a model that has a relation directly assignable to both public access AND userset with the same type. 2. A type bound public access tuple is assigned to an object. 3. userset tuple is not assigned to the same object. and 4. Check request's user field is a userset that has the same type as the type bound public access tuple's user type. Users are advised to upgrade to v1.8.5 which is backwards compatible. There are no known workarounds for this vulnerability.
Weakness: CWE-285
Which versions are affected by CVE-2025-25196?
3 open source packages ship an affected version, including github.com/openfga/openfga. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
github.com/openfga/openfga Go | All versions | 1.8.5 |
github.com/openfga/openfga Go | All versions | 1.8.5 |
github.com/openfga/openfga Go | All versions | 1.8.5 |
Products include Openfga Helm Charts, Openfga Openfga.
How do I fix CVE-2025-25196?
Upgrade github.com/openfga/openfga to 1.8.5 or later.
Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.
Is CVE-2025-25196 being exploited?
There is no known exploitation of CVE-2025-25196 in the wild and no public exploit code.
Other vulnerabilities in openfga
Sources
Also known as GHSA-g4v5-6f5p-m38j, GO-2025-3470, MINI-82vf-jfc7-jcpp, MINI-r599-c9wv-qhq5.