# CVE-2025-25201: Improper Validation of Admin Key in PIV Smartcard

> Attackers can bypass admin key validation to overwrite certificates and generate new keys in Nitrokey 3 PIV applications.

- **Severity:** Medium 4.0 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 12 Feb 2025
- **Updated:** 12 Feb 2025
- **Also known as:** GHSA-jfhm-ppq8-7hgx

## What is CVE-2025-25201?

CVE-2025-25201 is a medium-severity authentication bypass vulnerability in nitrokey-3-firmware, published on 12 Feb 2025. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Nitrokey 3 Firmware is the the firmware of Nitrokey 3 USB keys. For release 1.8.0, and test releases with PIV enabled prior to 1.8.0, the PIV application could accept invalid keys for authentication of the admin key. This could lead to compromise of the integrity of the data stored in the application. An attacker without access to the proper administration key would be able to generate new keys and overwrite certificates. Such an attacker would not be able to read-out or extract existing private data, nor would they be able to gain access to cryptographic operations that would normally require PIN-based authentication. The issue is fixed in piv-authenticator 0.3.9, and in Nitrokey's firmware 1.8.1.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2025-25201?


## How do I fix CVE-2025-25201?

No fix has been published for CVE-2025-25201 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-25201 being exploited?

There is no known exploitation of CVE-2025-25201 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-25201 and fix it if it is affected.

What it is: CVE-2025-25201 is a medium-severity authentication bypass vulnerability in nitrokey-3-firmware, published on 12 Feb 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-25201 in the wild and no public exploit code.

Affected product: nitrokey-3-firmware. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-25201/ (Markdown: https://insights.sbomify.com/CVE-2025-25201/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-25201
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-25201
- OSV: https://osv.dev/vulnerability/CVE-2025-25201

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-25201/
Summaries are generated and may contain mistakes; the official description above is the record.
