CVE-2025-25202 Ash Authentication has flawed token revocation checking logic in actions generated by `mix ash_authentication.install`

Medium 6.3 Published Updated

Attackers can reuse expired magic link tokens to access accounts if custom token revocation logic was generated by the installer.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-25202?

CVE-2025-25202 is a medium-severity authentication bypass vulnerability in team-alembic ash_authentication, published on 11 Feb 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Ash Authentication is an authentication framework for Elixir applications. Applications which have been bootstrapped by the igniter installer present since AshAuthentication v4.1.0 and who have used the magic link strategy _or_ are manually revoking tokens are affected by revoked tokens being allowed to verify as valid. Unless one hase implemented any kind of custom token revocation feature in your application, then one will not be affected. The impact here for users using builtin functionality is that magic link tokens are reusable until they expire. With that said, magic link tokens are only valid for 10 minutes, so the surface area for abuse is extremely low here. The flaw is patched in version 4.4.9. Additionally a compile time warning is shown to users with remediation instructions if they upgrade. 4.4.9 ships with an upgrader, so those who use `mix igniter.upgrade ash_authentication` will have the necessary patch applied. Otherwise, one may run the upgrader manually as described in the error message. As a workaround, delete the generated `:revoked?` generic action in the token resource. This will cause it to use the one internal to Ash Authentication which has always been correct. Alternatively, manually make the changes that are included in the patch.

Weakness: CWE-269

Which versions are affected by CVE-2025-25202?

2 open source packages ship an affected version, including ash_authentication. It affects 1 product.

PackageAffectedFixed in
ash_authentication HexFrom 4.1.04.4.9
ash_authentication HexFrom 4.1.04.4.9

Products include Alembic Ash Authentication.

How do I fix CVE-2025-25202?

Upgrade ash_authentication to 4.4.9 or later.

Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.

Is CVE-2025-25202 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-25202 exists.

Sources

Also known as GHSA-qrm9-f75w-hg4c.

Is CVE-2025-25202 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free