{"answers":{"affected":"2 open source packages ship an affected version, including ash_authentication. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-25202 exists.","fix":"Upgrade ash_authentication to 4.4.9 or later.","what":"CVE-2025-25202 is a medium-severity authentication bypass vulnerability in team-alembic ash_authentication, published on 11 Feb 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-25202 and fix it if it is affected.\n\nWhat it is: CVE-2025-25202 is a medium-severity authentication bypass vulnerability in team-alembic ash_authentication, published on 11 Feb 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-25202 exists.\n\nAffected packages and fixed versions:\n- ash_authentication (Hex): affected from 4.1.0; fixed in 4.4.9\n- ash_authentication (Hex): affected from 4.1.0; fixed in 4.4.9\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-25202/ (Markdown: https://insights.sbomify.com/CVE-2025-25202/index.md)","id":"CVE-2025-25202","markdown":"https://insights.sbomify.com/CVE-2025-25202/index.md","name":"CVE-2025-25202","record":{"aliases":["GHSA-qrm9-f75w-hg4c"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["account_takeover"],"network_reachable":"yes","non_default_config":true,"product_category":"Elixir authentication library","requires_auth":"none","summary":"Attackers can reuse expired magic link tokens to access accounts if custom token revocation logic was generated by the installer.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"ash_authentication","vendor":"alembic"}],"cvss":{"score":6.3,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-269","name":"Improper Privilege Management"}],"description":"Ash Authentication is an authentication framework for Elixir applications. Applications which have been bootstrapped by the igniter installer present since AshAuthentication v4.1.0 and who have used the magic link strategy _or_ are manually revoking tokens are affected by revoked tokens being allowed to verify as valid. Unless one hase implemented any kind of custom token revocation feature in your application, then one will not be affected. The impact here for users using builtin functionality is that magic link tokens are reusable until they expire. With that said, magic link tokens are only valid for 10 minutes, so the surface area for abuse is extremely low here. The flaw is patched in version 4.4.9. Additionally a compile time warning is shown to users with remediation instructions if they upgrade. 4.4.9 ships with an upgrader, so those who use `mix igniter.upgrade ash_authentication` will have the necessary patch applied. Otherwise, one may run the upgrader manually as described in the error message. As a workaround, delete the generated `:revoked?` generic action in the token resource. This will cause it to use the one internal to Ash Authentication which has always been correct. Alternatively, manually make the changes that are included in the patch.","ecosystems":["Hex"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Ash Authentication has flawed token revocation checking logic in actions generated by `mix ash_authentication.install`","id":"CVE-2025-25202","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Hex","product":null,"products":[],"type":"auth_bypass","year":"2025"},"n_packages":2,"n_references":2,"next":{"headline":"Ctrlpanel has stored XSS vulnerability in TicketsController priority field","id":"CVE-2025-25203"},"packages":[{"ecosystem":"Hex","fixed":["4.4.9"],"introduced":["4.1.0"],"last_affected":[],"package":"ash_authentication","purl":null,"source":"GHSA-qrm9-f75w-hg4c"},{"ecosystem":"Hex","fixed":["4.4.9"],"introduced":["4.1.0"],"last_affected":[],"package":"ash_authentication","purl":"pkg:hex/ash_authentication","source":"GHSA-qrm9-f75w-hg4c"}],"prev":{"headline":"Improper Validation of Admin Key in PIV Smartcard","id":"CVE-2025-25201"},"products":["ash_authentication"],"published":"2025-02-11","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-02-12","vendors":["team-alembic"]},"summary":"Attackers can reuse expired magic link tokens to access accounts if custom token revocation logic was generated by the installer.","url":"https://insights.sbomify.com/CVE-2025-25202/"}