{"answers":{"affected":"4 open source packages ship an affected version, including github.com/cli/cli/v2 and github.com/cli/cli.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-25204 exists.","fix":"Upgrade github.com/cli/cli/v2 to 2.67.0 or later.","what":"CVE-2025-25204 is a medium-severity vulnerability in cli, published on 14 Feb 2025. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-25204 and fix it if it is affected.\n\nWhat it is: CVE-2025-25204 is a medium-severity vulnerability in cli, published on 14 Feb 2025. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-25204 exists.\n\nAffected packages and fixed versions:\n- github.com/cli/cli/v2 (Go): affected from 2.49.0; fixed in 2.67.0\n- github.com/cli/cli/v2 (Go): affected from 2.49.0; fixed in 2.67.0\n- github.com/cli/cli/v2 (Go): affected from 2.49.0; fixed in 2.67.0\n- github.com/cli/cli (Go): affected all versions; no fix listed\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-25204/ (Markdown: https://insights.sbomify.com/CVE-2025-25204/index.md)","id":"CVE-2025-25204","markdown":"https://insights.sbomify.com/CVE-2025-25204/index.md","name":"CVE-2025-25204","record":{"aliases":["AZL-56885","GHSA-fgw4-v983-mgp8","GO-2025-3467"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"GitHub CLI","requires_auth":"low_privilege","summary":"The GitHub CLI incorrectly reports success when attestations are missing, allowing attackers to bypass deployment gates and install malicious artifacts.","user_interaction":"not_required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":6.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:N/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-390","name":"Detection of Error Condition Without Action"}],"description":"`gh` is GitHub’s official command line tool. Starting in version 2.49.0 and prior to version 2.67.0, under certain conditions, a bug in GitHub's Artifact Attestation cli tool `gh attestation verify` causes it to return a zero exit status when no attestations are present. This behavior is incorrect: When no attestations are present, `gh attestation verify` should return a non-zero exit status code, thereby signaling verification failure. An attacker can abuse this flaw to, for example, deploy malicious artifacts in any system that uses `gh attestation verify`'s exit codes to gatekeep deployments. Users are advised to update `gh` to patched version `v2.67.0` as soon as possible.","ecosystems":["Go"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"`gh attestation verify` returns incorrect exit code during verification if no attestations are present","id":"CVE-2025-25204","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Go","product":null,"products":[],"type":"security_feature_bypass","year":"2025"},"n_packages":4,"n_references":3,"next":{"headline":"Remote Authentication-Bypass can lead to server crash or limited information disclosure due to faulty pattern matching","id":"CVE-2025-25205"},"packages":[{"ecosystem":"Go","fixed":[],"introduced":["0"],"last_affected":[],"package":"github.com/cli/cli","purl":"pkg:golang/github.com/cli/cli","source":"GO-2025-3467"},{"ecosystem":"Go","fixed":["2.67.0"],"introduced":["2.49.0"],"last_affected":[],"package":"github.com/cli/cli/v2","purl":null,"source":"GHSA-fgw4-v983-mgp8"},{"ecosystem":"Go","fixed":["2.67.0"],"introduced":["2.49.0"],"last_affected":[],"package":"github.com/cli/cli/v2","purl":"pkg:golang/github.com/cli/cli/v2","source":"GHSA-fgw4-v983-mgp8"},{"ecosystem":"Go","fixed":["2.67.0"],"introduced":["2.49.0"],"last_affected":[],"package":"github.com/cli/cli/v2","purl":"pkg:golang/github.com/cli/cli/v2","source":"GO-2025-3467"}],"prev":{"headline":"Ctrlpanel has stored XSS vulnerability in TicketsController priority field","id":"CVE-2025-25203"},"products":["cli"],"published":"2025-02-14","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Go Vulnerability Database","prefix":"GO"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-03-03","vendors":["cli"]},"summary":"The GitHub CLI incorrectly reports success when attestations are missing, allowing attackers to bypass deployment gates and install malicious artifacts.","url":"https://insights.sbomify.com/CVE-2025-25204/"}