CVE-2025-25247 Apache Felix Webconsole: XSS in services console
An attacker can inject malicious scripts into the Apache Felix Webconsole services console, potentially executing code in the victim's browser.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2025-25247?
CVE-2025-25247 is a medium-severity cross-site scripting vulnerability in Apache Felix Webconsole, published on 10 Feb 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Apache Felix Webconsole.
This issue affects Apache Felix Webconsole 4.x up to 4.9.8 and 5.x up to 5.0.8.
Users are recommended to upgrade to version 4.9.10 or 5.0.10 or higher, which fixes the issue.
Weakness: CWE-79
Which versions are affected by CVE-2025-25247?
4 open source packages ship an affected version, including org.apache.felix:org.apache.felix.webconsole. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.felix:org.apache.felix.webconsole Maven | From 4.0.0 | 4.9.10 |
org.apache.felix:org.apache.felix.webconsole Maven | From 4.0.0 | 4.9.10 |
org.apache.felix:org.apache.felix.webconsole Maven | From 5.0.0 | 5.0.10 |
org.apache.felix:org.apache.felix.webconsole Maven | From 5.0.0 | 5.0.10 |
Products include Apache Felix Webconsole.
How do I fix CVE-2025-25247?
Upgrade org.apache.felix:org.apache.felix.webconsole to a fixed version for your release line: 4.9.10 or 5.0.10.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2025-25247 being exploited?
There is no known exploitation of CVE-2025-25247 in the wild and no public exploit code.
Sources
Also known as GHSA-4c37-7m5h-c8m9.