{"answers":{"affected":"4 open source packages ship an affected version, including org.apache.felix:org.apache.felix.webconsole. It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-25247 in the wild and no public exploit code.","fix":"Upgrade org.apache.felix:org.apache.felix.webconsole to a fixed version for your release line: 4.9.10 or 5.0.10.","what":"CVE-2025-25247 is a medium-severity cross-site scripting vulnerability in Apache Felix Webconsole, published on 10 Feb 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-25247 and fix it if it is affected.\n\nWhat it is: CVE-2025-25247 is a medium-severity cross-site scripting vulnerability in Apache Felix Webconsole, published on 10 Feb 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2025-25247 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.apache.felix:org.apache.felix.webconsole (Maven): affected from 4.0.0; fixed in 4.9.10\n- org.apache.felix:org.apache.felix.webconsole (Maven): affected from 4.0.0; fixed in 4.9.10\n- org.apache.felix:org.apache.felix.webconsole (Maven): affected from 5.0.0; fixed in 5.0.10\n- org.apache.felix:org.apache.felix.webconsole (Maven): affected from 5.0.0; fixed in 5.0.10\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-25247/ (Markdown: https://insights.sbomify.com/CVE-2025-25247/index.md)","id":"CVE-2025-25247","markdown":"https://insights.sbomify.com/CVE-2025-25247/index.md","name":"CVE-2025-25247","record":{"aliases":["GHSA-4c37-7m5h-c8m9"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Apache Felix Webconsole","requires_auth":"none","summary":"An attacker can inject malicious scripts into the Apache Felix Webconsole services console, potentially executing code in the victim's browser.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"felix_webconsole","vendor":"apache"}],"cvss":{"score":6.1,"severity":"medium","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Apache Felix Webconsole.\n\nThis issue affects Apache Felix Webconsole 4.x up to 4.9.8 and 5.x up to 5.0.8.\n\nUsers are recommended to upgrade to version 4.9.10 or 5.0.10 or higher, which fixes the issue.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apache Felix Webconsole: XSS in services console","id":"CVE-2025-25247","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"xss","year":"2025"},"n_packages":4,"n_references":1,"next":{"headline":"Integer overflow in FortiOS","id":"CVE-2025-25248"},"packages":[{"ecosystem":"Maven","fixed":["4.9.10"],"introduced":["4.0.0"],"last_affected":[],"package":"org.apache.felix:org.apache.felix.webconsole","purl":null,"source":"GHSA-4c37-7m5h-c8m9"},{"ecosystem":"Maven","fixed":["4.9.10"],"introduced":["4.0.0"],"last_affected":[],"package":"org.apache.felix:org.apache.felix.webconsole","purl":"pkg:maven/org.apache.felix/org.apache.felix.webconsole","source":"GHSA-4c37-7m5h-c8m9"},{"ecosystem":"Maven","fixed":["5.0.10"],"introduced":["5.0.0"],"last_affected":[],"package":"org.apache.felix:org.apache.felix.webconsole","purl":null,"source":"GHSA-4c37-7m5h-c8m9"},{"ecosystem":"Maven","fixed":["5.0.10"],"introduced":["5.0.0"],"last_affected":[],"package":"org.apache.felix:org.apache.felix.webconsole","purl":"pkg:maven/org.apache.felix/org.apache.felix.webconsole","source":"GHSA-4c37-7m5h-c8m9"}],"prev":{"headline":"Code injection in XR1000","id":"CVE-2025-25246"},"products":["Apache Felix Webconsole"],"published":"2025-02-10","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-02-10","vendors":["Apache Software Foundation"]},"summary":"An attacker can inject malicious scripts into the Apache Felix Webconsole services console, potentially executing code in the victim's browser.","url":"https://insights.sbomify.com/CVE-2025-25247/"}