CVE-2025-2527 Improper access control to group information
Attackers can view unauthorized group information via API requests due to improper permission verification in Mattermost.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-2527?
CVE-2025-2527 is a medium-severity missing authorization vulnerability in Mattermost Mattermost Server, published on 15 May 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Mattermost versions 10.5.x <= 10.5.2, 9.11.x <= 9.11.11 failed to properly verify a user's permissions when accessing groups, which allows an attacker to view group information via an API request.
Weakness: CWE-863
Which versions are affected by CVE-2025-2527?
10 open source packages ship an affected version, including github.com/mattermost/mattermost/server/v8, github.com/mattermost/mattermost-server and github.com/mattermost/mattermost-server/v5. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20250411064244-844447fbd57c |
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20250411064244-844447fbd57c |
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20250411064244-844447fbd57c |
github.com/mattermost/mattermost/server/v8 Go | From 10.5.0 | 10.5.3 |
github.com/mattermost/mattermost/server/v8 Go | From 10.5.0 | 10.5.3 |
github.com/mattermost/mattermost/server/v8 Go | From 9.11.0 | 9.11.12 |
4 more packages
github.com/mattermost/mattermost/server/v8 Go | From 9.11.0 | 9.11.12 |
github.com/mattermost/mattermost-server Go | From 9.11.0+incompatible | 9.11.12+incompatible, 10.5.3+incompatible |
github.com/mattermost/mattermost-server/v5 Go | All versions | None |
github.com/mattermost/mattermost-server/v6 Go | All versions | None |
Products include Mattermost Mattermost Server.
How do I fix CVE-2025-2527?
Upgrade github.com/mattermost/mattermost/server/v8 to a fixed version for your release line: 8.0.0-20250411064244-844447fbd57c, 10.5.3 or 9.11.12.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2025-2527 being exploited?
There is no known exploitation of CVE-2025-2527 in the wild and no public exploit code.
Other vulnerabilities in Mattermost Mattermost Server
- CVE-2025-12419 Account takeover on OAuth/OpenID-enabled servers
- CVE-2025-12421 Account Takeover via Code Exchange Endpoint
- CVE-2025-4981 Path Traversal Leading to RCE by Any Authenticated Mattermost User
- CVE-2025-20051 Arbitrary file read via block duplication in Mattermost Boards
- CVE-2025-25279 Arbitrary file read in Mattermost Boards via import & export board archive
Sources
Also known as GHSA-h356-3mfw-x368, GO-2025-3691.