CVE-2025-25274 Unauthorized Command Execution in Archived Channels
Authenticated users can execute commands in archived channels due to missing authorization checks, potentially leading to unauthorized code execution.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-25274?
CVE-2025-25274 is a medium-severity missing authorization vulnerability in Mattermost Mattermost Server, published on 21 Mar 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Mattermost versions 10.4.x <= 10.4.2, 10.3.x <= 10.3.3, 9.11.x <= 9.11.8 fail to restrict command execution in archived channels, which allows authenticated users to run commands in archived channels.
Which versions are affected by CVE-2025-25274?
13 open source packages ship an affected version, including github.com/mattermost/mattermost/server/v8, mattermost and github.com/mattermost/mattermost-server. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/mattermost/mattermost/server/v8 Go | All versions | None |
github.com/mattermost/mattermost/server/v8 Go | From 10.3.0 | 10.3.4 |
github.com/mattermost/mattermost/server/v8 Go | From 10.3.0 | 10.3.4 |
github.com/mattermost/mattermost/server/v8 Go | From 10.4.0 | 10.4.3 |
github.com/mattermost/mattermost/server/v8 Go | From 10.4.0 | 10.4.3 |
github.com/mattermost/mattermost/server/v8 Go | From 10.5.0 | 10.5.1 |
7 more packages
github.com/mattermost/mattermost/server/v8 Go | From 10.5.0 | 10.5.1 |
github.com/mattermost/mattermost/server/v8 Go | From 9.11.0 | 9.11.9 |
github.com/mattermost/mattermost/server/v8 Go | From 9.11.0 | 9.11.9 |
mattermost Bitnami | From 9.11.0 | 10.0.0, 10.5.1 |
github.com/mattermost/mattermost-server Go | From 9.11.0+incompatible | 9.11.9+incompatible, 10.3.4+incompatible, 10.4.3+incompatible, 10.5.1+incompatible |
github.com/mattermost/mattermost-server/v5 Go | All versions | None |
github.com/mattermost/mattermost-server/v6 Go | All versions | None |
Products include Mattermost Mattermost Server.
How do I fix CVE-2025-25274?
Upgrade github.com/mattermost/mattermost/server/v8 to a fixed version for your release line: 10.3.4, 10.4.3, 10.5.1 or 9.11.9.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2025-25274 being exploited?
There is no known exploitation of CVE-2025-25274 in the wild and no public exploit code.
Other vulnerabilities in Mattermost Mattermost Server
- CVE-2025-12419 Account takeover on OAuth/OpenID-enabled servers
- CVE-2025-12421 Account Takeover via Code Exchange Endpoint
- CVE-2025-4981 Path Traversal Leading to RCE by Any Authenticated Mattermost User
- CVE-2025-20051 Arbitrary file read via block duplication in Mattermost Boards
- CVE-2025-25279 Arbitrary file read in Mattermost Boards via import & export board archive
Sources
Also known as BIT-mattermost-2025-25274, GHSA-4v65-xqcj-wpgg, GO-2025-3550.