CVE-2025-25279 Arbitrary file read in Mattermost Boards via import & export board archive

Critical 9.9 Published Updated

An attacker can read arbitrary files on the system by importing a specially crafted board archive in Mattermost Boards.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-25279?

CVE-2025-25279 is a critical path traversal vulnerability in Mattermost Mattermost Server, published on 24 Feb 2025. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Mattermost versions 10.4.x <= 10.4.1, 9.11.x <= 9.11.7, 10.3.x <= 10.3.2, 10.2.x <= 10.2.2 fail to properly validate board blocks when importing boards which allows an attacker could read any arbitrary file on the system via importing and exporting a specially crafted import archive in Boards.

Weakness: CWE-22

Which versions are affected by CVE-2025-25279?

14 open source packages ship an affected version, including github.com/mattermost/mattermost/server/v8, github.com/mattermost/mattermost-server and github.com/mattermost/mattermost-server/v5. It affects 1 product.

PackageAffectedFixed in
github.com/mattermost/mattermost/server/v8 GoAll versions8.0.0-20250122165010-4ed702ccff4e
github.com/mattermost/mattermost/server/v8 GoAll versions8.0.0-20250122165010-4ed702ccff4e
github.com/mattermost/mattermost/server/v8 GoAll versions8.0.0-20250122165010-4ed702ccff4e
github.com/mattermost/mattermost/server/v8 GoFrom 10.2.0-rc110.2.3
github.com/mattermost/mattermost/server/v8 GoFrom 10.2.0-rc110.2.3
github.com/mattermost/mattermost/server/v8 GoFrom 10.3.0-rc110.3.3
8 more packages
github.com/mattermost/mattermost/server/v8 GoFrom 10.3.0-rc110.3.3
github.com/mattermost/mattermost/server/v8 GoFrom 10.4.0-rc110.4.2
github.com/mattermost/mattermost/server/v8 GoFrom 10.4.0-rc110.4.2
github.com/mattermost/mattermost/server/v8 GoFrom 9.11.0-rc19.11.8
github.com/mattermost/mattermost/server/v8 GoFrom 9.11.0-rc19.11.8
github.com/mattermost/mattermost-server GoFrom 9.11.0-rc1+incompatible9.11.8+incompatible, 10.2.3+incompatible, 10.3.3+incompatible, 10.4.2+incompatible
github.com/mattermost/mattermost-server/v5 GoAll versionsNone
github.com/mattermost/mattermost-server/v6 GoAll versionsNone

Products include Mattermost Mattermost Server.

How do I fix CVE-2025-25279?

Upgrade github.com/mattermost/mattermost/server/v8 to a fixed version for your release line: 8.0.0-20250122165010-4ed702ccff4e, 10.2.3, 10.3.3 or 10.4.2.

Upgrade, and resolve every user-supplied path against an allowed base folder before opening it. More about Path traversal.

Is CVE-2025-25279 being exploited?

There is no known exploitation of CVE-2025-25279 in the wild and no public exploit code.

Public exploit code: 2 proofs of concept on GitHub.

All Mattermost Mattermost Server vulnerabilities

Sources

Also known as GHSA-5fwx-p6xh-vjrh, GO-2025-3480.

Is CVE-2025-25279 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free