CVE-2025-25288 @octokit/plugin-paginate-rest has a Regular Expression in iterator Leads to ReDoS Vulnerability Due to Catastrophic Backtracking
Attackers can cause denial of service in applications using the Octokit pagination plugin by sending crafted headers that trigger catastrophic regex backtracking.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-25288?
CVE-2025-25288 is a medium-severity denial of service vulnerability in octokit plugin-paginate-rest.js, published on 14 Feb 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
@octokit/plugin-paginate-rest is the Octokit plugin to paginate REST API endpoint responses. For versions starting in 1.0.0 and prior to 11.4.1 of the npm package `@octokit/plugin-paginate-rest`, when calling `octokit.paginate.iterator()`, a specially crafted `octokit` instance—particularly with a malicious `link` parameter in the `headers` section of the `request`—can trigger a ReDoS attack. Version 11.4.1 contains a fix for the issue.
Weakness: CWE-1333
Which versions are affected by CVE-2025-25288?
4 open source packages ship an affected version, including @octokit/plugin-paginate-rest.
| Package | Affected | Fixed in |
|---|---|---|
@octokit/plugin-paginate-rest npm | From 1.0.0 | 9.2.2 |
@octokit/plugin-paginate-rest npm | From 1.0.0 | 9.2.2 |
@octokit/plugin-paginate-rest npm | From 9.3.0-beta.1 | 11.4.1 |
@octokit/plugin-paginate-rest npm | From 9.3.0-beta.1 | 11.4.1 |
How do I fix CVE-2025-25288?
Upgrade @octokit/plugin-paginate-rest to a fixed version for your release line: 9.2.2 or 11.4.1.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2025-25288 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-25288 exists.
Sources
Also known as CLSA-2026-1789898427, GHSA-h5c3-5r3r-rr8q, ROOT-APP-NPM-CVE-2025-25288.