{"answers":{"affected":"4 open source packages ship an affected version, including @octokit/plugin-paginate-rest.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-25288 exists.","fix":"Upgrade @octokit/plugin-paginate-rest to a fixed version for your release line: 9.2.2 or 11.4.1.","what":"CVE-2025-25288 is a medium-severity denial of service vulnerability in octokit plugin-paginate-rest.js, published on 14 Feb 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-25288 and fix it if it is affected.\n\nWhat it is: CVE-2025-25288 is a medium-severity denial of service vulnerability in octokit plugin-paginate-rest.js, published on 14 Feb 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-25288 exists.\n\nAffected packages and fixed versions:\n- @octokit/plugin-paginate-rest (npm): affected from 1.0.0; fixed in 9.2.2\n- @octokit/plugin-paginate-rest (npm): affected from 1.0.0; fixed in 9.2.2\n- @octokit/plugin-paginate-rest (npm): affected from 9.3.0-beta.1; fixed in 11.4.1\n- @octokit/plugin-paginate-rest (npm): affected from 9.3.0-beta.1; fixed in 11.4.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-25288/ (Markdown: https://insights.sbomify.com/CVE-2025-25288/index.md)","id":"CVE-2025-25288","markdown":"https://insights.sbomify.com/CVE-2025-25288/index.md","name":"CVE-2025-25288","record":{"aliases":["CLSA-2026-1789898427","GHSA-h5c3-5r3r-rr8q","ROOT-APP-NPM-CVE-2025-25288"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Octokit pagination plugin","requires_auth":"none","summary":"Attackers can cause denial of service in applications using the Octokit pagination plugin by sending crafted headers that trigger catastrophic regex backtracking.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L","version":"3.1"},"cwes":[{"id":"CWE-1333","name":"Inefficient Regular Expression Complexity"}],"description":"@octokit/plugin-paginate-rest is the Octokit plugin to paginate REST API endpoint responses. For versions starting in 1.0.0 and prior to 11.4.1 of the npm package `@octokit/plugin-paginate-rest`, when calling `octokit.paginate.iterator()`, a specially crafted `octokit` instance—particularly with a malicious `link` parameter in the `headers` section of the `request`—can trigger a ReDoS attack. Version 11.4.1 contains a fix for the issue.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"@octokit/plugin-paginate-rest has a Regular Expression in iterator Leads to ReDoS Vulnerability Due to Catastrophic Backtracking","id":"CVE-2025-25288","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2025"},"n_packages":4,"n_references":3,"next":{"headline":"@octokit/request-error has a Regular Expression in index that Leads to ReDoS Vulnerability Due to Catastrophic Backtracking","id":"CVE-2025-25289"},"packages":[{"ecosystem":"npm","fixed":["9.2.2"],"introduced":["1.0.0"],"last_affected":[],"package":"@octokit/plugin-paginate-rest","purl":null,"source":"GHSA-h5c3-5r3r-rr8q"},{"ecosystem":"npm","fixed":["9.2.2"],"introduced":["1.0.0"],"last_affected":[],"package":"@octokit/plugin-paginate-rest","purl":"pkg:npm/%40octokit/plugin-paginate-rest","source":"GHSA-h5c3-5r3r-rr8q"},{"ecosystem":"npm","fixed":["11.4.1"],"introduced":["9.3.0-beta.1"],"last_affected":[],"package":"@octokit/plugin-paginate-rest","purl":null,"source":"GHSA-h5c3-5r3r-rr8q"},{"ecosystem":"npm","fixed":["11.4.1"],"introduced":["9.3.0-beta.1"],"last_affected":[],"package":"@octokit/plugin-paginate-rest","purl":"pkg:npm/%40octokit/plugin-paginate-rest","source":"GHSA-h5c3-5r3r-rr8q"}],"prev":{"headline":"Lakeus vulnerable to stored XSS via system messages","id":"CVE-2025-25287"},"products":["plugin-paginate-rest.js"],"published":"2025-02-14","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-02-14","vendors":["octokit"]},"summary":"Attackers can cause denial of service in applications using the Octokit pagination plugin by sending crafted headers that trigger catastrophic regex backtracking.","url":"https://insights.sbomify.com/CVE-2025-25288/"}