CVE-2025-25289 @octokit/request-error has a Regular Expression in index that Leads to ReDoS Vulnerability Due to Catastrophic Backtracking

Medium 5.3 Published Updated

Attackers can cause denial of service in applications using this library by sending crafted HTTP headers that trigger catastrophic regex backtracking.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-25289?

CVE-2025-25289 is a medium-severity denial of service vulnerability in octokit request-error.js, published on 14 Feb 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

@octokit/request-error is an error class for Octokit request errors. Starting in version 1.0.0 and prior to version 6.1.7, a Regular Expression Denial of Service (ReDoS) vulnerability exists in the processing of HTTP request headers. By sending an authorization header containing an excessively long sequence of spaces followed by a newline and "@", an attacker can exploit inefficient regular expression processing, leading to excessive resource consumption. This can significantly degrade server performance or cause a denial-of-service (DoS) condition, impacting availability. Version 6.1.7 contains a fix for the issue.

Weakness: CWE-1333

Which versions are affected by CVE-2025-25289?

4 open source packages ship an affected version, including @octokit/request-error.

PackageAffectedFixed in
@octokit/request-error npmFrom 1.0.05.1.1
@octokit/request-error npmFrom 1.0.05.1.1
@octokit/request-error npmFrom 6.0.06.1.7
@octokit/request-error npmFrom 6.0.06.1.7

How do I fix CVE-2025-25289?

Upgrade @octokit/request-error to a fixed version for your release line: 5.1.1 or 6.1.7.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2025-25289 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-25289 exists.

Sources

Also known as CLSA-2026-1793208276, GHSA-xx4v-prfh-6cgc, MINI-95fg-8v9w-37cc, MINI-fxv9-hhjp-r5h6, MINI-qg8q-g66p-vqwc, ROOT-APP-NPM-CVE-2025-25289.

Is CVE-2025-25289 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free