{"answers":{"affected":"4 open source packages ship an affected version, including @octokit/request-error.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-25289 exists.","fix":"Upgrade @octokit/request-error to a fixed version for your release line: 5.1.1 or 6.1.7.","what":"CVE-2025-25289 is a medium-severity denial of service vulnerability in octokit request-error.js, published on 14 Feb 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-25289 and fix it if it is affected.\n\nWhat it is: CVE-2025-25289 is a medium-severity denial of service vulnerability in octokit request-error.js, published on 14 Feb 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-25289 exists.\n\nAffected packages and fixed versions:\n- @octokit/request-error (npm): affected from 1.0.0; fixed in 5.1.1\n- @octokit/request-error (npm): affected from 1.0.0; fixed in 5.1.1\n- @octokit/request-error (npm): affected from 6.0.0; fixed in 6.1.7\n- @octokit/request-error (npm): affected from 6.0.0; fixed in 6.1.7\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-25289/ (Markdown: https://insights.sbomify.com/CVE-2025-25289/index.md)","id":"CVE-2025-25289","markdown":"https://insights.sbomify.com/CVE-2025-25289/index.md","name":"CVE-2025-25289","record":{"aliases":["CLSA-2026-1793208276","GHSA-xx4v-prfh-6cgc","MINI-95fg-8v9w-37cc","MINI-fxv9-hhjp-r5h6","MINI-qg8q-g66p-vqwc","ROOT-APP-NPM-CVE-2025-25289"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"JavaScript HTTP library","requires_auth":"none","summary":"Attackers can cause denial of service in applications using this library by sending crafted HTTP headers that trigger catastrophic regex backtracking.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L","version":"3.1"},"cwes":[{"id":"CWE-1333","name":"Inefficient Regular Expression Complexity"}],"description":"@octokit/request-error is an error class for Octokit request errors. Starting in version 1.0.0 and prior to version 6.1.7, a Regular Expression Denial of Service (ReDoS) vulnerability exists in the processing of HTTP request headers. By sending an authorization header containing an excessively long sequence of spaces followed by a newline and \"@\", an attacker can exploit inefficient regular expression processing, leading to excessive resource consumption. This can significantly degrade server performance or cause a denial-of-service (DoS) condition, impacting availability. Version 6.1.7 contains a fix for the issue.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"@octokit/request-error has a Regular Expression in index that Leads to ReDoS Vulnerability Due to Catastrophic Backtracking","id":"CVE-2025-25289","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2025"},"n_packages":4,"n_references":3,"next":{"headline":"@octokit/request has a Regular Expression in fetchWrapper that Leads to ReDoS Vulnerability Due to Catastrophic Backtracking","id":"CVE-2025-25290"},"packages":[{"ecosystem":"npm","fixed":["5.1.1"],"introduced":["1.0.0"],"last_affected":[],"package":"@octokit/request-error","purl":null,"source":"GHSA-xx4v-prfh-6cgc"},{"ecosystem":"npm","fixed":["5.1.1"],"introduced":["1.0.0"],"last_affected":[],"package":"@octokit/request-error","purl":"pkg:npm/%40octokit/request-error","source":"GHSA-xx4v-prfh-6cgc"},{"ecosystem":"npm","fixed":["6.1.7"],"introduced":["6.0.0"],"last_affected":[],"package":"@octokit/request-error","purl":null,"source":"GHSA-xx4v-prfh-6cgc"},{"ecosystem":"npm","fixed":["6.1.7"],"introduced":["6.0.0"],"last_affected":[],"package":"@octokit/request-error","purl":"pkg:npm/%40octokit/request-error","source":"GHSA-xx4v-prfh-6cgc"}],"prev":{"headline":"@octokit/plugin-paginate-rest has a Regular Expression in iterator Leads to ReDoS Vulnerability Due to Catastrophic Backtracking","id":"CVE-2025-25288"},"products":["request-error.js"],"published":"2025-02-14","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-02-14","vendors":["octokit"]},"summary":"Attackers can cause denial of service in applications using this library by sending crafted HTTP headers that trigger catastrophic regex backtracking.","url":"https://insights.sbomify.com/CVE-2025-25289/"}