# CVE-2025-25289: @octokit/request-error has a Regular Expression in index that Leads to ReDoS Vulnerability Due to Catastrophic Backtracking

> Attackers can cause denial of service in applications using this library by sending crafted HTTP headers that trigger catastrophic regex backtracking.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Feb 2025
- **Updated:** 14 Feb 2025
- **Also known as:** CLSA-2026-1793208276, GHSA-xx4v-prfh-6cgc, MINI-95fg-8v9w-37cc, MINI-fxv9-hhjp-r5h6, MINI-qg8q-g66p-vqwc, ROOT-APP-NPM-CVE-2025-25289

## What is CVE-2025-25289?

CVE-2025-25289 is a medium-severity denial of service vulnerability in octokit request-error.js, published on 14 Feb 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

@octokit/request-error is an error class for Octokit request errors. Starting in version 1.0.0 and prior to version 6.1.7, a Regular Expression Denial of Service (ReDoS) vulnerability exists in the processing of HTTP request headers. By sending an authorization header containing an excessively long sequence of spaces followed by a newline and "@", an attacker can exploit inefficient regular expression processing, leading to excessive resource consumption. This can significantly degrade server performance or cause a denial-of-service (DoS) condition, impacting availability. Version 6.1.7 contains a fix for the issue.

Weakness: CWE-1333 (Inefficient Regular Expression Complexity)

## Which versions are affected by CVE-2025-25289?

4 open source packages ship an affected version, including @octokit/request-error.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@octokit/request-error` | npm | From 1.0.0 | 5.1.1 |
| `@octokit/request-error` | npm | From 1.0.0 | 5.1.1 |
| `@octokit/request-error` | npm | From 6.0.0 | 6.1.7 |
| `@octokit/request-error` | npm | From 6.0.0 | 6.1.7 |

## How do I fix CVE-2025-25289?

Upgrade @octokit/request-error to a fixed version for your release line: 5.1.1 or 6.1.7.

## Is CVE-2025-25289 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-25289 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-25289 and fix it if it is affected.

What it is: CVE-2025-25289 is a medium-severity denial of service vulnerability in octokit request-error.js, published on 14 Feb 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-25289 exists.

Affected packages and fixed versions:
- @octokit/request-error (npm): affected from 1.0.0; fixed in 5.1.1
- @octokit/request-error (npm): affected from 1.0.0; fixed in 5.1.1
- @octokit/request-error (npm): affected from 6.0.0; fixed in 6.1.7
- @octokit/request-error (npm): affected from 6.0.0; fixed in 6.1.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-25289/ (Markdown: https://insights.sbomify.com/CVE-2025-25289/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-25289
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-25289
- OSV: https://osv.dev/vulnerability/CVE-2025-25289

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-25289/
Summaries are generated and may contain mistakes; the official description above is the record.
