CVE-2025-25290 @octokit/request has a Regular Expression in fetchWrapper that Leads to ReDoS Vulnerability Due to Catastrophic Backtracking
Attackers can cause denial of service in applications using @octokit/request by sending malicious link headers that trigger catastrophic regex backtracking.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-25290?
CVE-2025-25290 is a medium-severity denial of service vulnerability in octokit request.js, published on 14 Feb 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
@octokit/request sends parameterized requests to GitHub’s APIs with sensible defaults in browsers and Node. Starting in version 1.0.0 and prior to versions 9.2.1 and 8.4.1, the regular expression `/<([^>]+)>; rel="deprecation"/` used to match the `link` header in HTTP responses is vulnerable to a ReDoS (Regular Expression Denial of Service) attack. This vulnerability arises due to the unbounded nature of the regex's matching behavior, which can lead to catastrophic backtracking when processing specially crafted input. An attacker could exploit this flaw by sending a malicious `link` header, resulting in excessive CPU usage and potentially causing the server to become unresponsive, impacting service availability. Versions 9.2.1 and 8.4.1 fix the issue.
Weakness: CWE-1333
Which versions are affected by CVE-2025-25290?
4 open source packages ship an affected version, including @octokit/request.
| Package | Affected | Fixed in |
|---|---|---|
@octokit/request npm | From 1.0.0 | 8.4.1 |
@octokit/request npm | From 1.0.0 | 8.4.1 |
@octokit/request npm | From 9.0.0-beta.1 | 9.2.1 |
@octokit/request npm | From 9.0.0-beta.1 | 9.2.1 |
How do I fix CVE-2025-25290?
Upgrade @octokit/request to a fixed version for your release line: 8.4.1 or 9.2.1.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2025-25290 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-25290 exists.
Sources
Also known as CLEANSTART-2026-HA47621, CLSA-2026-1793208261, GHSA-rmvr-2pp2-xj38, MINI-26c5-fjpj-wmw6, MINI-54vv-5qf5-c5mj, MINI-8q73-48f5-rr86 and 1 more.