# CVE-2025-25290: @octokit/request has a Regular Expression in fetchWrapper that Leads to ReDoS Vulnerability Due to Catastrophic Backtracking

> Attackers can cause denial of service in applications using @octokit/request by sending malicious link headers that trigger catastrophic regex backtracking.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Feb 2025
- **Updated:** 16 Jan 2026
- **Also known as:** CLEANSTART-2026-HA47621, CLSA-2026-1793208261, GHSA-rmvr-2pp2-xj38, MINI-26c5-fjpj-wmw6, MINI-54vv-5qf5-c5mj, MINI-8q73-48f5-rr86, ROOT-APP-NPM-CVE-2025-25290

## What is CVE-2025-25290?

CVE-2025-25290 is a medium-severity denial of service vulnerability in octokit request.js, published on 14 Feb 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

@octokit/request sends parameterized requests to GitHub’s APIs with sensible defaults in browsers and Node. Starting in version 1.0.0 and prior to versions 9.2.1 and 8.4.1, the regular expression `/<([^>]+)>; rel="deprecation"/` used to match the `link` header in HTTP responses is vulnerable to a ReDoS (Regular Expression Denial of Service) attack. This vulnerability arises due to the unbounded nature of the regex's matching behavior, which can lead to catastrophic backtracking when processing specially crafted input. An attacker could exploit this flaw by sending a malicious `link` header, resulting in excessive CPU usage and potentially causing the server to become unresponsive, impacting service availability. Versions 9.2.1 and 8.4.1 fix the issue.

Weakness: CWE-1333 (Inefficient Regular Expression Complexity)

## Which versions are affected by CVE-2025-25290?

4 open source packages ship an affected version, including @octokit/request.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@octokit/request` | npm | From 1.0.0 | 8.4.1 |
| `@octokit/request` | npm | From 1.0.0 | 8.4.1 |
| `@octokit/request` | npm | From 9.0.0-beta.1 | 9.2.1 |
| `@octokit/request` | npm | From 9.0.0-beta.1 | 9.2.1 |

## How do I fix CVE-2025-25290?

Upgrade @octokit/request to a fixed version for your release line: 8.4.1 or 9.2.1.

## Is CVE-2025-25290 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-25290 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-25290 and fix it if it is affected.

What it is: CVE-2025-25290 is a medium-severity denial of service vulnerability in octokit request.js, published on 14 Feb 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-25290 exists.

Affected packages and fixed versions:
- @octokit/request (npm): affected from 1.0.0; fixed in 8.4.1
- @octokit/request (npm): affected from 1.0.0; fixed in 8.4.1
- @octokit/request (npm): affected from 9.0.0-beta.1; fixed in 9.2.1
- @octokit/request (npm): affected from 9.0.0-beta.1; fixed in 9.2.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-25290/ (Markdown: https://insights.sbomify.com/CVE-2025-25290/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-25290
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-25290
- OSV: https://osv.dev/vulnerability/CVE-2025-25290

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-25290/
Summaries are generated and may contain mistakes; the official description above is the record.
