{"answers":{"affected":"5 open source packages ship an affected version, including ruby-saml and gitlab. It affects 3 products.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-25291 exists.","fix":"Upgrade ruby-saml to a fixed version for your release line: 1.12.4 or 1.18.0.","what":"CVE-2025-25291 is a critical authentication bypass vulnerability in Netapp Storagegrid, published on 12 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-25291 and fix it if it is affected.\n\nWhat it is: CVE-2025-25291 is a critical authentication bypass vulnerability in Netapp Storagegrid, published on 12 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-25291 exists.\n\nAffected packages and fixed versions:\n- ruby-saml (RubyGems): affected all versions; fixed in 1.12.4\n- ruby-saml (RubyGems): affected all versions; fixed in 1.12.4\n- ruby-saml (RubyGems): affected from 1.13.0; fixed in 1.18.0\n- ruby-saml (RubyGems): affected from 1.13.0; fixed in 1.18.0\n- gitlab (Bitnami): affected all versions; fixed in 17.9.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-25291/ (Markdown: https://insights.sbomify.com/CVE-2025-25291/index.md)","id":"CVE-2025-25291","markdown":"https://insights.sbomify.com/CVE-2025-25291/index.md","name":"CVE-2025-25291","record":{"aliases":["BIT-gitlab-2025-25291","DEBIAN-CVE-2025-25291","GHSA-4vc4-m8qh-g8jm","UBUNTU-CVE-2025-25291"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby SAML library","requires_auth":"none","summary":"An attacker can bypass SAML authentication in ruby-saml by exploiting parser differences to execute a Signature Wrapping attack.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"storagegrid","vendor":"netapp"},{"product":"omniauth_saml","vendor":"omniauth"},{"product":"ruby-saml","vendor":"onelogin"}],"cvss":{"score":9.3,"severity":"critical","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-436","name":"Interpretation Conflict"},{"id":"CWE-347","name":"Improper Verification of Cryptographic Signature"}],"description":"ruby-saml provides security assertion markup language (SAML) single sign-on (SSO) for Ruby. An authentication bypass vulnerability was found in ruby-saml prior to versions 1.12.4 and 1.18.0 due to a parser differential. ReXML and Nokogiri parse XML differently; the parsers can generate entirely different document structures from the same XML input. That allows an attacker to be able to execute a Signature Wrapping attack. This issue may lead to authentication bypass. Versions 1.12.4 and 1.18.0 fix the issue.","ecosystems":["Bitnami","RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"ruby-saml vulnerable to SAML authentication bypass due to DOCTYPE handling (parser differential)","id":"CVE-2025-25291","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"netapp:storagegrid","products":["netapp:storagegrid"],"type":"auth_bypass","year":"2025"},"n_packages":5,"n_references":10,"next":{"headline":"Ruby SAML vulnerable to SAML authentication bypass due to namespace handling (parser differential)","id":"CVE-2025-25292"},"packages":[{"ecosystem":"Bitnami","fixed":["17.9.2"],"introduced":["0"],"last_affected":[],"package":"gitlab","purl":"pkg:bitnami/gitlab","source":"BIT-gitlab-2025-25291"},{"ecosystem":"RubyGems","fixed":["1.12.4"],"introduced":["0"],"last_affected":[],"package":"ruby-saml","purl":null,"source":"GHSA-4vc4-m8qh-g8jm"},{"ecosystem":"RubyGems","fixed":["1.12.4"],"introduced":["0"],"last_affected":[],"package":"ruby-saml","purl":"pkg:gem/ruby-saml","source":"GHSA-4vc4-m8qh-g8jm"},{"ecosystem":"RubyGems","fixed":["1.18.0"],"introduced":["1.13.0"],"last_affected":[],"package":"ruby-saml","purl":null,"source":"GHSA-4vc4-m8qh-g8jm"},{"ecosystem":"RubyGems","fixed":["1.18.0"],"introduced":["1.13.0"],"last_affected":[],"package":"ruby-saml","purl":"pkg:gem/ruby-saml","source":"GHSA-4vc4-m8qh-g8jm"}],"prev":{"headline":"@octokit/request has a Regular Expression in fetchWrapper that Leads to ReDoS Vulnerability Due to Catastrophic Backtracking","id":"CVE-2025-25290"},"products":["ruby-saml"],"published":"2025-03-12","related":[{"cvss_score":9.3,"headline":"Ruby SAML vulnerable to SAML authentication bypass due to namespace handling (parser differential)","id":"CVE-2025-25292","kev_date_added":null,"published":"2025-03-12"},{"cvss_score":7.5,"headline":"CVE-2025-26515 Server-Side Request Forgery Vulnerability in StorageGRID (formerly StorageGRID Webscale)","id":"CVE-2025-26515","kev_date_added":null,"published":"2025-09-19"},{"cvss_score":7.5,"headline":"Denial of service in Denial of Service Vulnerability in StorageGRID (formerly StorageGRID Webscale)","id":"CVE-2022-38734","kev_date_added":null,"published":"2023-03-02"},{"cvss_score":7.5,"headline":"Denial of service in StorageGRID (formerly StorageGRID Webscale)","id":"CVE-2022-23233","kev_date_added":null,"published":"2022-03-04"},{"cvss_score":7.5,"headline":"Denial of service in StorageGRID (formerly StorageGRID Webscale)","id":"CVE-2020-8571","kev_date_added":null,"published":"2020-03-13"},{"cvss_score":6.5,"headline":"Denial of Service Vulnerability in StorageGRID (formerly StorageGRID Webscale)","id":"CVE-2024-21983","kev_date_added":null,"published":"2024-02-16"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-11-03","vendors":["SAML-Toolkits"]},"summary":"An attacker can bypass SAML authentication in ruby-saml by exploiting parser differences to execute a Signature Wrapping attack.","url":"https://insights.sbomify.com/CVE-2025-25291/"}