CVE-2025-25293 ruby-saml vulnerable to Remote Denial of Service (DoS) with compressed SAML responses
Attackers can cause remote denial of service in ruby-saml by sending compressed SAML responses that bypass size checks during inflation.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-25293?
CVE-2025-25293 is a high-severity denial of service vulnerability in SAML-Toolkits ruby-saml, published on 12 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
ruby-saml provides security assertion markup language (SAML) single sign-on (SSO) for Ruby. Prior to versions 1.12.4 and 1.18.0, ruby-saml is susceptible to remote Denial of Service (DoS) with compressed SAML responses. ruby-saml uses zlib to decompress SAML responses in case they're compressed. It is possible to bypass the message size check with a compressed assertion since the message size is checked before inflation and not after. This issue may lead to remote Denial of Service (DoS). Versions 1.12.4 and 1.18.0 fix the issue.
Weakness: CWE-400
Which versions are affected by CVE-2025-25293?
5 open source packages ship an affected version, including ruby-saml and gitlab. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
ruby-saml RubyGems | All versions | 1.12.4 |
ruby-saml RubyGems | All versions | 1.12.4 |
ruby-saml RubyGems | From 1.13.0 | 1.18.0 |
ruby-saml RubyGems | From 1.13.0 | 1.18.0 |
gitlab Bitnami | All versions | 17.9.2 |
Products include Omniauth Omniauth Saml, Onelogin Ruby-Saml.
How do I fix CVE-2025-25293?
Upgrade ruby-saml to a fixed version for your release line: 1.12.4 or 1.18.0.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2025-25293 being exploited?
There is no known exploitation of CVE-2025-25293 in the wild and no public exploit code.
Other vulnerabilities in SAML-Toolkits ruby-saml
Sources
Also known as BIT-gitlab-2025-25293, DEBIAN-CVE-2025-25293, GHSA-92rq-c8cf-prrq, UBUNTU-CVE-2025-25293.