{"answers":{"affected":"5 open source packages ship an affected version, including ruby-saml and gitlab. It affects 2 products.","exploited":"There is no known exploitation of CVE-2025-25293 in the wild and no public exploit code.","fix":"Upgrade ruby-saml to a fixed version for your release line: 1.12.4 or 1.18.0.","what":"CVE-2025-25293 is a high-severity denial of service vulnerability in SAML-Toolkits ruby-saml, published on 12 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-25293 and fix it if it is affected.\n\nWhat it is: CVE-2025-25293 is a high-severity denial of service vulnerability in SAML-Toolkits ruby-saml, published on 12 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-25293 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- ruby-saml (RubyGems): affected all versions; fixed in 1.12.4\n- ruby-saml (RubyGems): affected all versions; fixed in 1.12.4\n- ruby-saml (RubyGems): affected from 1.13.0; fixed in 1.18.0\n- ruby-saml (RubyGems): affected from 1.13.0; fixed in 1.18.0\n- gitlab (Bitnami): affected all versions; fixed in 17.9.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-25293/ (Markdown: https://insights.sbomify.com/CVE-2025-25293/index.md)","id":"CVE-2025-25293","markdown":"https://insights.sbomify.com/CVE-2025-25293/index.md","name":"CVE-2025-25293","record":{"aliases":["BIT-gitlab-2025-25293","DEBIAN-CVE-2025-25293","GHSA-92rq-c8cf-prrq","UBUNTU-CVE-2025-25293"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby SAML library","requires_auth":"none","summary":"Attackers can cause remote denial of service in ruby-saml by sending compressed SAML responses that bypass size checks during inflation.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"omniauth_saml","vendor":"omniauth"},{"product":"ruby-saml","vendor":"onelogin"}],"cvss":{"score":7.7,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N/E:P","version":"4.0"},"cwes":[{"id":"CWE-400","name":"Uncontrolled Resource Consumption"}],"description":"ruby-saml provides security assertion markup language (SAML) single sign-on (SSO) for Ruby. Prior to versions 1.12.4 and 1.18.0, ruby-saml is susceptible to remote Denial of Service (DoS) with compressed SAML responses. ruby-saml uses zlib to decompress SAML responses in case they're compressed. It is possible to bypass the message size check with a compressed assertion since the message size is checked before inflation and not after. This issue may lead to remote Denial of Service (DoS). Versions 1.12.4 and 1.18.0 fix the issue.","ecosystems":["Bitnami","RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"ruby-saml vulnerable to Remote Denial of Service (DoS) with compressed SAML responses","id":"CVE-2025-25293","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"denial_of_service","year":"2025"},"n_packages":5,"n_references":9,"next":{"headline":"Envoy Gateway Log Injection Vulnerability","id":"CVE-2025-25294"},"packages":[{"ecosystem":"Bitnami","fixed":["17.9.2"],"introduced":["0"],"last_affected":[],"package":"gitlab","purl":"pkg:bitnami/gitlab","source":"BIT-gitlab-2025-25293"},{"ecosystem":"RubyGems","fixed":["1.12.4"],"introduced":["0"],"last_affected":[],"package":"ruby-saml","purl":null,"source":"GHSA-92rq-c8cf-prrq"},{"ecosystem":"RubyGems","fixed":["1.12.4"],"introduced":["0"],"last_affected":[],"package":"ruby-saml","purl":"pkg:gem/ruby-saml","source":"GHSA-92rq-c8cf-prrq"},{"ecosystem":"RubyGems","fixed":["1.18.0"],"introduced":["1.13.0"],"last_affected":[],"package":"ruby-saml","purl":null,"source":"GHSA-92rq-c8cf-prrq"},{"ecosystem":"RubyGems","fixed":["1.18.0"],"introduced":["1.13.0"],"last_affected":[],"package":"ruby-saml","purl":"pkg:gem/ruby-saml","source":"GHSA-92rq-c8cf-prrq"}],"prev":{"headline":"Ruby SAML vulnerable to SAML authentication bypass due to namespace handling (parser differential)","id":"CVE-2025-25292"},"products":["ruby-saml"],"published":"2025-03-12","related":[{"cvss_score":7.7,"headline":"Multiple SAML libraries may allow authentication bypass via incorrect XML canonicalization and DOM traversal","id":"CVE-2017-11430","kev_date_added":null,"published":"2019-04-17"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-11-03","vendors":["SAML-Toolkits"]},"summary":"Attackers can cause remote denial of service in ruby-saml by sending compressed SAML responses that bypass size checks during inflation.","url":"https://insights.sbomify.com/CVE-2025-25293/"}