# CVE-2025-25293: ruby-saml vulnerable to Remote Denial of Service (DoS) with compressed SAML responses

> Attackers can cause remote denial of service in ruby-saml by sending compressed SAML responses that bypass size checks during inflation.

- **Severity:** High 7.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Mar 2025
- **Updated:** 3 Nov 2025
- **Also known as:** BIT-gitlab-2025-25293, DEBIAN-CVE-2025-25293, GHSA-92rq-c8cf-prrq, UBUNTU-CVE-2025-25293

## What is CVE-2025-25293?

CVE-2025-25293 is a high-severity denial of service vulnerability in SAML-Toolkits ruby-saml, published on 12 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

ruby-saml provides security assertion markup language (SAML) single sign-on (SSO) for Ruby. Prior to versions 1.12.4 and 1.18.0, ruby-saml is susceptible to remote Denial of Service (DoS) with compressed SAML responses. ruby-saml uses zlib to decompress SAML responses in case they're compressed. It is possible to bypass the message size check with a compressed assertion since the message size is checked before inflation and not after. This issue may lead to remote Denial of Service (DoS). Versions 1.12.4 and 1.18.0 fix the issue.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2025-25293?

5 open source packages ship an affected version, including ruby-saml and gitlab. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ruby-saml` | RubyGems | All versions | 1.12.4 |
| `ruby-saml` | RubyGems | All versions | 1.12.4 |
| `ruby-saml` | RubyGems | From 1.13.0 | 1.18.0 |
| `ruby-saml` | RubyGems | From 1.13.0 | 1.18.0 |
| `gitlab` | Bitnami | All versions | 17.9.2 |

Products: Omniauth Omniauth Saml, Onelogin Ruby-Saml.

## How do I fix CVE-2025-25293?

Upgrade ruby-saml to a fixed version for your release line: 1.12.4 or 1.18.0.

## Is CVE-2025-25293 being exploited?

There is no known exploitation of CVE-2025-25293 in the wild and no public exploit code.

## Other vulnerabilities in SAML-Toolkits ruby-saml

- [CVE-2017-11430](https://insights.sbomify.com/CVE-2017-11430/): Multiple SAML libraries may allow authentication bypass via incorrect XML canonicalization and DOM traversal (high 7.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-25293 and fix it if it is affected.

What it is: CVE-2025-25293 is a high-severity denial of service vulnerability in SAML-Toolkits ruby-saml, published on 12 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-25293 in the wild and no public exploit code.

Affected packages and fixed versions:
- ruby-saml (RubyGems): affected all versions; fixed in 1.12.4
- ruby-saml (RubyGems): affected all versions; fixed in 1.12.4
- ruby-saml (RubyGems): affected from 1.13.0; fixed in 1.18.0
- ruby-saml (RubyGems): affected from 1.13.0; fixed in 1.18.0
- gitlab (Bitnami): affected all versions; fixed in 17.9.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-25293/ (Markdown: https://insights.sbomify.com/CVE-2025-25293/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-25293
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-25293
- OSV: https://osv.dev/vulnerability/CVE-2025-25293

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-25293/
Summaries are generated and may contain mistakes; the official description above is the record.
