# CVE-2025-25294: Envoy Gateway Log Injection Vulnerability

> Attackers can inject JSON into access logs via crafted user-agent strings, potentially corrupting log data in Envoy Gateway deployments.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Mar 2025
- **Updated:** 6 Mar 2025
- **Also known as:** BIT-envoy-gateway-2025-25294, CLEANSTART-2026-DL05775, CLEANSTART-2026-GL17744, GHSA-mf24-chxh-hmvj, GO-2025-3504

## What is CVE-2025-25294?

CVE-2025-25294 is a medium-severity vulnerability in envoyproxy gateway, published on 6 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Envoy Gateway is an open source project for managing Envoy Proxy as a standalone or Kubernetes-based application gateway. In all Envoy Gateway versions prior to 1.2.7 and 1.3.1 a default Envoy Proxy access log configuration is used. This format is vulnerable to log injection attacks. If the attacker uses a specially crafted user-agent which performs json injection, then he could add and overwrite fields to the access log. This vulnerability is fixed in 1.3.1 and 1.2.7. One can overwrite the old text based default format with JSON formatter by modifying the "EnvoyProxy.spec.telemetry.accessLog" setting.

Weakness: CWE-117 (Improper Output Neutralization for Logs)

## Which versions are affected by CVE-2025-25294?

6 open source packages ship an affected version, including github.com/envoyproxy/gateway and envoy-gateway. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/envoyproxy/gateway` | Go | All versions | 1.2.7, 1.3.1 |
| `github.com/envoyproxy/gateway` | Go | All versions | 1.2.7 |
| `github.com/envoyproxy/gateway` | Go | All versions | 1.2.7 |
| `github.com/envoyproxy/gateway` | Go | From 1.3.0-rc.1 | 1.3.1 |
| `github.com/envoyproxy/gateway` | Go | From 1.3.0-rc.1 | 1.3.1 |
| `envoy-gateway` | Bitnami | All versions | 1.2.7, 1.3.1 |

Products: Envoyproxy Gateway.

## How do I fix CVE-2025-25294?

Upgrade github.com/envoyproxy/gateway to a fixed version for your release line: 1.2.7 or 1.3.1.

## Is CVE-2025-25294 being exploited?

There is no known exploitation of CVE-2025-25294 in the wild and no public exploit code.

## Other vulnerabilities in envoyproxy gateway

- [CVE-2026-22771](https://insights.sbomify.com/CVE-2026-22771/): Envoy Extension Policy lua scripts injection causes arbitrary command execution (high 8.8)
- [CVE-2025-24030](https://insights.sbomify.com/CVE-2025-24030/): Envoy Admin Interface Exposed through prometheus metrics endpoint (high 7.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-25294 and fix it if it is affected.

What it is: CVE-2025-25294 is a medium-severity vulnerability in envoyproxy gateway, published on 6 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-25294 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/envoyproxy/gateway (Go): affected all versions; fixed in 1.2.7, 1.3.1
- github.com/envoyproxy/gateway (Go): affected all versions; fixed in 1.2.7
- github.com/envoyproxy/gateway (Go): affected all versions; fixed in 1.2.7
- github.com/envoyproxy/gateway (Go): affected from 1.3.0-rc.1; fixed in 1.3.1
- github.com/envoyproxy/gateway (Go): affected from 1.3.0-rc.1; fixed in 1.3.1
- envoy-gateway (Bitnami): affected all versions; fixed in 1.2.7, 1.3.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-25294/ (Markdown: https://insights.sbomify.com/CVE-2025-25294/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-25294
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-25294
- OSV: https://osv.dev/vulnerability/CVE-2025-25294

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-25294/
Summaries are generated and may contain mistakes; the official description above is the record.
