# CVE-2025-25298: Missing Maximum Password Length Validation in Strapi Password Hashing

> Strapi fails to limit password length, allowing silent truncation of passwords over 72 bytes, which reduces entropy and may facilitate unauthorized access.

- **Severity:** Medium 6.3 (`CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Oct 2025
- **Updated:** 16 Oct 2025
- **Also known as:** GHSA-2cjv-6wg9-f4f3

## What is CVE-2025-25298?

CVE-2025-25298 is a medium-severity vulnerability in strapi, published on 16 Oct 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Strapi is an open source headless CMS. The @strapi/core package before version 5.10.3 does not enforce a maximum password length when using bcryptjs for password hashing. Bcryptjs ignores any bytes beyond 72, so passwords longer than 72 bytes are silently truncated. A user can create an account with a password exceeding 72 bytes and later authenticate with only the first 72 bytes. This reduces the effective entropy of overlong passwords and may mislead users who believe characters beyond 72 bytes are required, creating a low likelihood of unintended authentication if an attacker can obtain or guess the truncated portion. Long over‑length inputs can also impose unnecessary processing overhead. The issue is fixed in version 5.10.3. No known workarounds exist.

Weakness: CWE-261 (Weak Encoding for Password)

## Which versions are affected by CVE-2025-25298?

2 open source packages ship an affected version, including @strapi/core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@strapi/core` | npm | All versions | 5.10.3 |
| `@strapi/core` | npm | All versions | 5.10.3 |

Products: Strapi Strapi.

## How do I fix CVE-2025-25298?

Upgrade @strapi/core to 5.10.3 or later.

## Is CVE-2025-25298 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-25298 exists.

## Other vulnerabilities in strapi

- [CVE-2023-22894](https://insights.sbomify.com/CVE-2023-22894/): Strapi Cleartext Storage of Sensitive Information (high 7.2, exploited in the wild)
- [CVE-2023-22621](https://insights.sbomify.com/CVE-2023-22621/): Strapi plugins vulnerable to Server-Side Template Injection and Remote Code Execution in the Users-Permissions Plugin (critical 10.0)
- [CVE-2022-27263](https://insights.sbomify.com/CVE-2022-27263/): Unrestricted Upload of File with Dangerous Type in Strapi (critical 9.8)
- [CVE-2020-27664](https://insights.sbomify.com/CVE-2020-27664/): Authorization bypass in Strapi (critical 9.8)
- [CVE-2019-18818](https://insights.sbomify.com/CVE-2019-18818/): Strapi allows unauthenticated attacker to reset admin password without valid reset token (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-25298 and fix it if it is affected.

What it is: CVE-2025-25298 is a medium-severity vulnerability in strapi, published on 16 Oct 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-25298 exists.

Affected packages and fixed versions:
- @strapi/core (npm): affected all versions; fixed in 5.10.3
- @strapi/core (npm): affected all versions; fixed in 5.10.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-25298/ (Markdown: https://insights.sbomify.com/CVE-2025-25298/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-25298
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-25298
- OSV: https://osv.dev/vulnerability/CVE-2025-25298

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-25298/
Summaries are generated and may contain mistakes; the official description above is the record.
