{"answers":{"affected":"4 open source packages ship an affected version, including @ckeditor/ckeditor5-real-time-collaboration and ckeditor5-premium-features.","exploited":"There is no known exploitation of CVE-2025-25299 in the wild and no public exploit code.","fix":"Upgrade @ckeditor/ckeditor5-real-time-collaboration to 44.2.1 or later.","what":"CVE-2025-25299 is a low-severity cross-site scripting vulnerability in ckeditor5, published on 20 Feb 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-25299 and fix it if it is affected.\n\nWhat it is: CVE-2025-25299 is a low-severity cross-site scripting vulnerability in ckeditor5, published on 20 Feb 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2025-25299 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- @ckeditor/ckeditor5-real-time-collaboration (npm): affected from 41.3.0; fixed in 44.2.1\n- @ckeditor/ckeditor5-real-time-collaboration (npm): affected from 41.3.0; fixed in 44.2.1\n- ckeditor5-premium-features (npm): affected from 42.0.0; fixed in 44.2.1\n- ckeditor5-premium-features (npm): affected from 42.0.0; fixed in 44.2.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-25299/ (Markdown: https://insights.sbomify.com/CVE-2025-25299/index.md)","id":"CVE-2025-25299","markdown":"https://insights.sbomify.com/CVE-2025-25299/index.md","name":"CVE-2025-25299","record":{"aliases":["GHSA-j3mm-wmfm-mwvh","UBUNTU-CVE-2025-25299"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":true,"product_category":"JavaScript rich-text editor","requires_auth":"none","summary":"An XSS vulnerability in CKEditor 5's real-time collaboration package allows unauthorized JavaScript execution when specific configurations are enabled.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":2.3,"severity":"low","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-80","name":"Improper Neutralization of Script-Related HTML Tags in a Web Page"},{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"CKEditor 5 is a modern JavaScript rich-text editor with an MVC architecture. During a recent internal audit, a Cross-Site Scripting (XSS) vulnerability was discovered in the CKEditor 5 real-time collaboration package. This vulnerability affects user markers, which represent users' positions within the document. It can lead to unauthorized JavaScript code execution, which might happen with a very specific editor and token endpoint configuration. This vulnerability affects only installations with Real-time collaborative editing enabled. The problem has been recognized and patched. The fix is available in version 44.2.1 (and above). Users are advised to upgrade. There are no known workarounds for this vulnerability.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Cross-site scripting (XSS) in the real-time collaboration package","id":"CVE-2025-25299","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2025"},"n_packages":4,"n_references":3,"next":{"headline":"smartbanner.js rel noopener XSS vulnerability","id":"CVE-2025-25300"},"packages":[{"ecosystem":"npm","fixed":["44.2.1"],"introduced":["41.3.0"],"last_affected":[],"package":"@ckeditor/ckeditor5-real-time-collaboration","purl":null,"source":"GHSA-j3mm-wmfm-mwvh"},{"ecosystem":"npm","fixed":["44.2.1"],"introduced":["41.3.0"],"last_affected":[],"package":"@ckeditor/ckeditor5-real-time-collaboration","purl":"pkg:npm/%40ckeditor/ckeditor5-real-time-collaboration","source":"GHSA-j3mm-wmfm-mwvh"},{"ecosystem":"npm","fixed":["44.2.1"],"introduced":["42.0.0"],"last_affected":[],"package":"ckeditor5-premium-features","purl":null,"source":"GHSA-j3mm-wmfm-mwvh"},{"ecosystem":"npm","fixed":["44.2.1"],"introduced":["42.0.0"],"last_affected":[],"package":"ckeditor5-premium-features","purl":"pkg:npm/ckeditor5-premium-features","source":"GHSA-j3mm-wmfm-mwvh"}],"prev":{"headline":"Missing Maximum Password Length Validation in Strapi Password Hashing","id":"CVE-2025-25298"},"products":["ckeditor5"],"published":"2025-02-20","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-02-20","vendors":["ckeditor"]},"summary":"An XSS vulnerability in CKEditor 5's real-time collaboration package allows unauthorized JavaScript execution when specific configurations are enabled.","url":"https://insights.sbomify.com/CVE-2025-25299/"}