# CVE-2025-25299: Cross-site scripting (XSS) in the real-time collaboration package

> An XSS vulnerability in CKEditor 5's real-time collaboration package allows unauthorized JavaScript execution when specific configurations are enabled.

- **Severity:** Low 2.3 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 20 Feb 2025
- **Updated:** 20 Feb 2025
- **Also known as:** GHSA-j3mm-wmfm-mwvh, UBUNTU-CVE-2025-25299

## What is CVE-2025-25299?

CVE-2025-25299 is a low-severity cross-site scripting vulnerability in ckeditor5, published on 20 Feb 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

CKEditor 5 is a modern JavaScript rich-text editor with an MVC architecture. During a recent internal audit, a Cross-Site Scripting (XSS) vulnerability was discovered in the CKEditor 5 real-time collaboration package. This vulnerability affects user markers, which represent users' positions within the document. It can lead to unauthorized JavaScript code execution, which might happen with a very specific editor and token endpoint configuration. This vulnerability affects only installations with Real-time collaborative editing enabled. The problem has been recognized and patched. The fix is available in version 44.2.1 (and above). Users are advised to upgrade. There are no known workarounds for this vulnerability.

Weakness: CWE-80 (Improper Neutralization of Script-Related HTML Tags in a Web Page), CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-25299?

4 open source packages ship an affected version, including @ckeditor/ckeditor5-real-time-collaboration and ckeditor5-premium-features.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@ckeditor/ckeditor5-real-time-collaboration` | npm | From 41.3.0 | 44.2.1 |
| `@ckeditor/ckeditor5-real-time-collaboration` | npm | From 41.3.0 | 44.2.1 |
| `ckeditor5-premium-features` | npm | From 42.0.0 | 44.2.1 |
| `ckeditor5-premium-features` | npm | From 42.0.0 | 44.2.1 |

## How do I fix CVE-2025-25299?

Upgrade @ckeditor/ckeditor5-real-time-collaboration to 44.2.1 or later.

## Is CVE-2025-25299 being exploited?

There is no known exploitation of CVE-2025-25299 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-25299 and fix it if it is affected.

What it is: CVE-2025-25299 is a low-severity cross-site scripting vulnerability in ckeditor5, published on 20 Feb 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-25299 in the wild and no public exploit code.

Affected packages and fixed versions:
- @ckeditor/ckeditor5-real-time-collaboration (npm): affected from 41.3.0; fixed in 44.2.1
- @ckeditor/ckeditor5-real-time-collaboration (npm): affected from 41.3.0; fixed in 44.2.1
- ckeditor5-premium-features (npm): affected from 42.0.0; fixed in 44.2.1
- ckeditor5-premium-features (npm): affected from 42.0.0; fixed in 44.2.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-25299/ (Markdown: https://insights.sbomify.com/CVE-2025-25299/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-25299
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-25299
- OSV: https://osv.dev/vulnerability/CVE-2025-25299

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-25299/
Summaries are generated and may contain mistakes; the official description above is the record.
