# CVE-2025-25300: smartbanner.js rel noopener XSS vulnerability


- **Severity:** Low 1.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:L/VA:N/SC:L/SI:L/SA:N/E:U`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 18 Feb 2025
- **Updated:** 18 Feb 2025
- **Also known as:** GHSA-9mrq-cjgh-32g2

## What is CVE-2025-25300?

CVE-2025-25300 is a low-severity vulnerability in ain smartbanner.js, published on 18 Feb 2025. 

### Official description

smartbanner.js is a customizable smart app banner for iOS and Android. Prior to version 1.14.1, clicking on smartbanner `View` link and navigating to 3rd party page leaves `window.opener` exposed. It may allow hostile third parties to abuse `window.opener`, e.g. by redirection or injection on the original page with smartbanner. `rel="noopener"` is automatically populated to links as of `v1.14.1` which is a recommended upgrade to resolve the vulnerability. Some workarounds are available for those who cannot upgrade. Ensure `View` link is only taking users to App Store or Google Play Store where security is guarded by respective app store security teams. If `View` link is going to a third party page, limit smartbanner.js to be used on iOS that decreases the scope of the vulnerability since as of Safari 12.1,  `rel="noopener"` is imposed on all `target="_blank"` links. Version 1.14.1 of smartbanner.js contains a fix for the issue.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation), CWE-601 (URL Redirection to Untrusted Site)

## Which versions are affected by CVE-2025-25300?

2 open source packages ship an affected version, including smartbanner.js.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `smartbanner.js` | npm | All versions | 1.14.1 |
| `smartbanner.js` | npm | All versions | 1.14.1 |

## How do I fix CVE-2025-25300?

Upgrade smartbanner.js to 1.14.1 or later.

## Is CVE-2025-25300 being exploited?

There is no known exploitation of CVE-2025-25300 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-25300 and fix it if it is affected.

What it is: CVE-2025-25300 is a low-severity vulnerability in ain smartbanner.js, published on 18 Feb 2025. 
Exploitation: There is no known exploitation of CVE-2025-25300 in the wild and no public exploit code.

Affected packages and fixed versions:
- smartbanner.js (npm): affected all versions; fixed in 1.14.1
- smartbanner.js (npm): affected all versions; fixed in 1.14.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-25300/ (Markdown: https://insights.sbomify.com/CVE-2025-25300/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-25300
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-25300
- OSV: https://osv.dev/vulnerability/CVE-2025-25300

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-25300/
Summaries are generated and may contain mistakes; the official description above is the record.
