{"answers":{"affected":"4 open source packages ship an affected version, including vega and vega-selections.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-25304 exists.","fix":"Upgrade vega to 5.26.0 or later.","what":"CVE-2025-25304 is a medium-severity cross-site scripting vulnerability in vega, published on 14 Feb 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-25304 and fix it if it is affected.\n\nWhat it is: CVE-2025-25304 is a medium-severity cross-site scripting vulnerability in vega, published on 14 Feb 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-25304 exists.\n\nAffected packages and fixed versions:\n- vega (npm): affected all versions; fixed in 5.26.0\n- vega (npm): affected all versions; fixed in 5.26.0\n- vega-selections (npm): affected all versions; fixed in 5.4.2\n- vega-selections (npm): affected all versions; fixed in 5.4.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-25304/ (Markdown: https://insights.sbomify.com/CVE-2025-25304/index.md)","id":"CVE-2025-25304","markdown":"https://insights.sbomify.com/CVE-2025-25304/index.md","name":"CVE-2025-25304","record":{"aliases":["DEBIAN-CVE-2025-25304","GHSA-mp7w-mhcv-673j","UBUNTU-CVE-2025-25304"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Vega visualization library","requires_auth":"none","summary":"Attackers can execute arbitrary JavaScript via the vlSelectionTuples function in Vega, potentially compromising user sessions or data.","user_interaction":"not_required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":6.9,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N","version":"4.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Vega is a visualization grammar, a declarative format for creating, saving, and sharing interactive visualization designs. Prior to version 5.26.0 of vega and 5.4.2 of vega-selections, the `vlSelectionTuples` function can be used to call JavaScript functions, leading to cross-site scripting.`vlSelectionTuples` calls multiple functions that can be controlled by an attacker, including one call with an attacker-controlled argument. This can be used to call `Function()` with arbitrary JavaScript and the resulting function can be called with `vlSelectionTuples` or using a type coercion to call `toString` or `valueOf`. Version 5.26.0 of vega and 5.4.2 of vega-selections fix this issue.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Vega allows Cross-site Scripting via the vlSelectionTuples function","id":"CVE-2025-25304","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2025"},"n_packages":4,"n_references":3,"next":{"headline":"SSL validation for outgoing requests in Home Assistant Core and used libs not correct","id":"CVE-2025-25305"},"packages":[{"ecosystem":"npm","fixed":["5.26.0"],"introduced":["0"],"last_affected":[],"package":"vega","purl":null,"source":"GHSA-mp7w-mhcv-673j"},{"ecosystem":"npm","fixed":["5.26.0"],"introduced":["0"],"last_affected":[],"package":"vega","purl":"pkg:npm/vega","source":"GHSA-mp7w-mhcv-673j"},{"ecosystem":"npm","fixed":["5.4.2"],"introduced":["0"],"last_affected":[],"package":"vega-selections","purl":null,"source":"GHSA-mp7w-mhcv-673j"},{"ecosystem":"npm","fixed":["5.4.2"],"introduced":["0"],"last_affected":[],"package":"vega-selections","purl":"pkg:npm/vega-selections","source":"GHSA-mp7w-mhcv-673j"}],"prev":{"headline":"Server-Side Request Forgery (SSRF) in MouseTooltipTranslator","id":"CVE-2025-25303"},"products":["vega"],"published":"2025-02-14","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-02-14","vendors":["vega"]},"summary":"Attackers can execute arbitrary JavaScript via the vlSelectionTuples function in Vega, potentially compromising user sessions or data.","url":"https://insights.sbomify.com/CVE-2025-25304/"}