# CVE-2025-25304: Vega allows Cross-site Scripting via the vlSelectionTuples function

> Attackers can execute arbitrary JavaScript via the vlSelectionTuples function in Vega, potentially compromising user sessions or data.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Feb 2025
- **Updated:** 14 Feb 2025
- **Also known as:** DEBIAN-CVE-2025-25304, GHSA-mp7w-mhcv-673j, UBUNTU-CVE-2025-25304

## What is CVE-2025-25304?

CVE-2025-25304 is a medium-severity cross-site scripting vulnerability in vega, published on 14 Feb 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Vega is a visualization grammar, a declarative format for creating, saving, and sharing interactive visualization designs. Prior to version 5.26.0 of vega and 5.4.2 of vega-selections, the `vlSelectionTuples` function can be used to call JavaScript functions, leading to cross-site scripting.`vlSelectionTuples` calls multiple functions that can be controlled by an attacker, including one call with an attacker-controlled argument. This can be used to call `Function()` with arbitrary JavaScript and the resulting function can be called with `vlSelectionTuples` or using a type coercion to call `toString` or `valueOf`. Version 5.26.0 of vega and 5.4.2 of vega-selections fix this issue.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-25304?

4 open source packages ship an affected version, including vega and vega-selections.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vega` | npm | All versions | 5.26.0 |
| `vega` | npm | All versions | 5.26.0 |
| `vega-selections` | npm | All versions | 5.4.2 |
| `vega-selections` | npm | All versions | 5.4.2 |

## How do I fix CVE-2025-25304?

Upgrade vega to 5.26.0 or later.

## Is CVE-2025-25304 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-25304 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-25304 and fix it if it is affected.

What it is: CVE-2025-25304 is a medium-severity cross-site scripting vulnerability in vega, published on 14 Feb 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-25304 exists.

Affected packages and fixed versions:
- vega (npm): affected all versions; fixed in 5.26.0
- vega (npm): affected all versions; fixed in 5.26.0
- vega-selections (npm): affected all versions; fixed in 5.4.2
- vega-selections (npm): affected all versions; fixed in 5.4.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-25304/ (Markdown: https://insights.sbomify.com/CVE-2025-25304/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-25304
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-25304
- OSV: https://osv.dev/vulnerability/CVE-2025-25304

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-25304/
Summaries are generated and may contain mistakes; the official description above is the record.
