{"answers":{"affected":"3 open source packages ship an affected version, including homeassistant.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-25305 exists.","fix":"Upgrade homeassistant to 2024.1.6 or later.","what":"CVE-2025-25305 is a high-severity vulnerability in home-assistant core, published on 18 Feb 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-25305 and fix it if it is affected.\n\nWhat it is: CVE-2025-25305 is a high-severity vulnerability in home-assistant core, published on 18 Feb 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-25305 exists.\n\nAffected packages and fixed versions:\n- homeassistant (PyPI): affected all versions; fixed in 2024.1.6\n- homeassistant (PyPI): affected all versions; fixed in 2024.1.6\n- homeassistant (PyPI): affected all versions; fixed in 2024.1.6\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-25305/ (Markdown: https://insights.sbomify.com/CVE-2025-25305/index.md)","id":"CVE-2025-25305","markdown":"https://insights.sbomify.com/CVE-2025-25305/index.md","name":"CVE-2025-25305","record":{"aliases":["GHSA-m3pm-rpgg-5wj6","PYSEC-2026-1452"],"analysis":{"component_type":"iot_embedded","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Home automation platform","requires_auth":"none","summary":"Home Assistant Core fails to verify SSL certificates due to incorrect parameter migration, allowing man-in-the-middle attacks on outgoing requests.","user_interaction":"not_required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":7,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-940","name":"Improper Verification of Source of a Communication Channel"}],"description":"Home Assistant Core is an open source home automation that puts local control and privacy first. Affected versions are subject to a potential man-in-the-middle attacks due to missing SSL certificate verification in the project codebase and used third-party libraries. In the past, `aiohttp-session`/`request` had the parameter `verify_ssl` to control SSL certificate verification. This was a boolean value. In `aiohttp` 3.0, this parameter was deprecated in favor of the `ssl` parameter. Only when `ssl` is set to `None` or provided with a correct configured SSL context the standard SSL certificate verification will happen. When migrating integrations in Home Assistant and libraries used by Home Assistant, in some cases the `verify_ssl` parameter value was just moved to the new `ssl` parameter. This resulted in these integrations and 3rd party libraries using `request.ssl = True`, which unintentionally turned off SSL certificate verification and opened up a man-in-the-middle attack vector. This issue has been addressed in version 2024.1.6 and all users are advised to upgrade. There are no known workarounds for this vulnerability.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"SSL validation for outgoing requests in Home Assistant Core and used libs not correct","id":"CVE-2025-25305","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"security_feature_bypass","year":"2025"},"n_packages":3,"n_references":1,"next":{"headline":"Misskey's Incomplete Patch of CVE-2024-52591 Leads to Forgery of Federated Notes","id":"CVE-2025-25306"},"packages":[{"ecosystem":"PyPI","fixed":["2024.1.6"],"introduced":["0"],"last_affected":[],"package":"homeassistant","purl":null,"source":"GHSA-m3pm-rpgg-5wj6"},{"ecosystem":"PyPI","fixed":["2024.1.6"],"introduced":["0"],"last_affected":[],"package":"homeassistant","purl":"pkg:pypi/homeassistant","source":"GHSA-m3pm-rpgg-5wj6"},{"ecosystem":"PyPI","fixed":["2024.1.6"],"introduced":["0"],"last_affected":[],"package":"homeassistant","purl":"pkg:pypi/homeassistant","source":"PYSEC-2026-1452"}],"prev":{"headline":"Vega allows Cross-site Scripting via the vlSelectionTuples function","id":"CVE-2025-25304"},"products":["core"],"published":"2025-02-18","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-02-18","vendors":["home-assistant"]},"summary":"Home Assistant Core fails to verify SSL certificates due to incorrect parameter migration, allowing man-in-the-middle attacks on outgoing requests.","url":"https://insights.sbomify.com/CVE-2025-25305/"}