# CVE-2025-25497: Missing authorization in n/a

> Attackers can unauthorizedly reassign account ownership in Netsweeper Server due to missing server-side validation, enabling privilege escalation and data modification.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 6 Mar 2025
- **Updated:** 7 Mar 2025
- **Also known as:** GHSA-2jvp-r7m9-xhpr

## What is CVE-2025-25497?

CVE-2025-25497 is a high-severity missing authorization vulnerability in n/a, published on 6 Mar 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

An issue in account management interface in Netsweeper Server v.8.2.6 and earlier (fixed in v.8.2.7) allows unauthorized changes to the "Account Owner" field due to client-side-only restrictions and a lack of server-side validation. This vulnerability enables account ownership reassignment to or away from any user.

Weakness: CWE-602 (Client-Side Enforcement of Server-Side Security)

## Which versions are affected by CVE-2025-25497?


## How do I fix CVE-2025-25497?

No fix has been published for CVE-2025-25497 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-25497 being exploited?

There is no known exploitation of CVE-2025-25497 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-25497 and fix it if it is affected.

What it is: CVE-2025-25497 is a high-severity missing authorization vulnerability in n/a, published on 6 Mar 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-25497 in the wild and no public exploit code.

Affected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-25497/ (Markdown: https://insights.sbomify.com/CVE-2025-25497/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-25497
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-25497
- OSV: https://osv.dev/vulnerability/CVE-2025-25497

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-25497/
Summaries are generated and may contain mistakes; the official description above is the record.
