CVE-2025-2564 Unauthorized View Access to Archived Channel Member Info

Medium 4.3 Published Updated

Authenticated users can view archived channel member information despite disabled settings, exposing private data in Mattermost.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-2564?

CVE-2025-2564 is a medium-severity missing authorization vulnerability in Mattermost Mattermost Server, published on 16 Apr 2025. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Mattermost versions 10.5.x <= 10.5.1, 10.4.x <= 10.4.3, 9.11.x <= 9.11.9 fail to properly enforce the 'Allow users to view/update archived channels' System Console setting, which allows authenticated users to view members and member information of archived channels even when this setting is disabled.

Weakness: CWE-863

Which versions are affected by CVE-2025-2564?

12 open source packages ship an affected version, including github.com/mattermost/mattermost/server/v8, github.com/mattermost/mattermost-server and github.com/mattermost/mattermost-server/v5. It affects 1 product.

PackageAffectedFixed in
github.com/mattermost/mattermost/server/v8 GoAll versions8.0.0-20250314142426-c049748b8863
github.com/mattermost/mattermost/server/v8 GoAll versions8.0.0-20250314142426-c049748b8863
github.com/mattermost/mattermost/server/v8 GoAll versions8.0.0-20250314142426-c049748b8863
github.com/mattermost/mattermost/server/v8 GoFrom 10.4.010.4.4
github.com/mattermost/mattermost/server/v8 GoFrom 10.4.010.4.4
github.com/mattermost/mattermost/server/v8 GoFrom 10.5.010.5.2
6 more packages
github.com/mattermost/mattermost/server/v8 GoFrom 10.5.010.5.2
github.com/mattermost/mattermost/server/v8 GoFrom 9.11.09.11.10
github.com/mattermost/mattermost/server/v8 GoFrom 9.11.09.11.10
github.com/mattermost/mattermost-server GoFrom 9.11.0+incompatible9.11.10+incompatible, 10.4.4+incompatible, 10.5.2+incompatible
github.com/mattermost/mattermost-server/v5 GoAll versionsNone
github.com/mattermost/mattermost-server/v6 GoAll versionsNone

Products include Mattermost Mattermost Server.

How do I fix CVE-2025-2564?

Upgrade github.com/mattermost/mattermost/server/v8 to a fixed version for your release line: 8.0.0-20250314142426-c049748b8863, 10.4.4, 10.5.2 or 9.11.10.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2025-2564 being exploited?

There is no known exploitation of CVE-2025-2564 in the wild and no public exploit code.

All Mattermost Mattermost Server vulnerabilities

Sources

Also known as GHSA-mj2p-v2c2-vh4v, GO-2025-3623.

Is CVE-2025-2564 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free