CVE-2025-2570 System Admin Cannot Access Environment settings in System Console While System Manager Can
A System Manager can bypass restrictions to access experimental settings in the System Console when the RestrictSystemAdmin setting is enabled.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-2570?
CVE-2025-2570 is a low-severity missing authorization vulnerability in Mattermost Mattermost Server, published on 15 May 2025. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
Mattermost versions 10.5.x <= 10.5.3, 9.11.x <= 9.11.11 fail to check `RestrictSystemAdmin` setting if user doesn't have access to `ExperimentalSettings` which allows a System Manager to access `ExperimentSettings` when `RestrictSystemAdmin` is true via System Console.
Weakness: CWE-863
Which versions are affected by CVE-2025-2570?
10 open source packages ship an affected version, including github.com/mattermost/mattermost/server/v8, github.com/mattermost/mattermost-server and github.com/mattermost/mattermost-server/v5. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20250411064244-844447fbd57c |
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20250411064244-844447fbd57c |
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20250411064244-844447fbd57c |
github.com/mattermost/mattermost/server/v8 Go | From 10.5.0 | 10.5.3 |
github.com/mattermost/mattermost/server/v8 Go | From 10.5.0 | 10.5.3 |
github.com/mattermost/mattermost/server/v8 Go | From 9.11.0 | 9.11.12 |
4 more packages
github.com/mattermost/mattermost/server/v8 Go | From 9.11.0 | 9.11.12 |
github.com/mattermost/mattermost-server Go | From 9.11.0+incompatible | 9.11.12+incompatible, 10.5.3+incompatible |
github.com/mattermost/mattermost-server/v5 Go | All versions | None |
github.com/mattermost/mattermost-server/v6 Go | All versions | None |
Products include Mattermost Mattermost Server.
How do I fix CVE-2025-2570?
Upgrade github.com/mattermost/mattermost/server/v8 to a fixed version for your release line: 8.0.0-20250411064244-844447fbd57c, 10.5.3 or 9.11.12.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2025-2570 being exploited?
There is no known exploitation of CVE-2025-2570 in the wild and no public exploit code.
Other vulnerabilities in Mattermost Mattermost Server
- CVE-2025-12419 Account takeover on OAuth/OpenID-enabled servers
- CVE-2025-12421 Account Takeover via Code Exchange Endpoint
- CVE-2025-4981 Path Traversal Leading to RCE by Any Authenticated Mattermost User
- CVE-2025-20051 Arbitrary file read via block duplication in Mattermost Boards
- CVE-2025-25279 Arbitrary file read in Mattermost Boards via import & export board archive
Sources
Also known as GHSA-fpff-wj6m-grvr, GO-2025-3694.