{"answers":{"affected":"1 open source package ship an affected version, including pyassimp. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-2592 exists.","fix":"Apply the vendor's patch.","what":"CVE-2025-2592 is a medium-severity memory corruption vulnerability in Open Asset Import Library Assimp, published on 21 Mar 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-2592 and fix it if it is affected.\n\nWhat it is: CVE-2025-2592 is a medium-severity memory corruption vulnerability in Open Asset Import Library Assimp, published on 21 Mar 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-2592 exists.\n\nAffected packages and fixed versions:\n- pyassimp (PyPI): affected all versions up to 5.4.3; no fix listed\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-2592/ (Markdown: https://insights.sbomify.com/CVE-2025-2592/index.md)","id":"CVE-2025-2592","markdown":"https://insights.sbomify.com/CVE-2025-2592/index.md","name":"CVE-2025-2592","record":{"aliases":["DEBIAN-CVE-2025-2592","GHSA-gq4x-2qp9-2gvw","PYSEC-2025-260","UBUNTU-CVE-2025-2592","openSUSE-SU-2025:0117-1"],"analysis":{"component_type":"library","fix_type":"patch","impacts":["code_execution","denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"3D model import library","requires_auth":"none","summary":"A heap-based buffer overflow in Assimp's CSMLoader allows remote attackers to execute arbitrary code or cause denial of service via crafted files.","user_interaction":"required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[{"product":"assimp","vendor":"assimp"}],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-122","name":"Heap-based Buffer Overflow"},{"id":"CWE-119","name":"Improper Restriction of Operations within the Bounds of a Memory Buffer"}],"description":"A vulnerability, which was classified as critical, has been found in Open Asset Import Library Assimp 5.4.3. This issue affects the function CSMImporter::InternReadFile of the file code/AssetLib/CSM/CSMLoader.cpp. The manipulation leads to heap-based buffer overflow. The attack may be initiated remotely. The exploit has been disclosed to the public and may be used. The patch is named 2690e354da0c681db000cfd892a55226788f2743. It is recommended to apply a patch to fix this issue.","ecosystems":["PyPI","SUSE:Package Hub 15 SP6","openSUSE:Leap 15.6"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Open Asset Import Library Assimp CSMLoader.cpp InternReadFile heap-based overflow","id":"CVE-2025-2592","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"memory_corruption","year":"2025"},"n_packages":3,"n_references":7,"next":{"headline":"FastCMS list sql injection","id":"CVE-2025-2593"},"packages":[{"ecosystem":"PyPI","fixed":[],"introduced":["0"],"last_affected":["5.4.3"],"package":"pyassimp","purl":"pkg:pypi/pyassimp","source":"PYSEC-2025-260"},{"ecosystem":"SUSE:Package Hub 15 SP6","fixed":["2.3.1-bp156.4.3.1"],"introduced":["0"],"last_affected":[],"package":"doomsday","purl":"pkg:rpm/suse/doomsday\u0026distro=SUSE%20Package%20Hub%2015%20SP6","source":"openSUSE-SU-2025:0117-1"},{"ecosystem":"openSUSE:Leap 15.6","fixed":["2.3.1-bp156.4.3.1"],"introduced":["0"],"last_affected":[],"package":"doomsday","purl":"pkg:rpm/opensuse/doomsday\u0026distro=openSUSE%20Leap%2015.6","source":"openSUSE-SU-2025:0117-1"}],"prev":{"headline":"Open Asset Import Library Assimp MDLLoader.cpp InternReadFile_Quake1 divide by zero","id":"CVE-2025-2591"},"products":["Assimp"],"published":"2025-03-21","related":[{"cvss_score":8.8,"headline":"Use after free in n/a","id":"CVE-2022-45748","kev_date_added":null,"published":"2023-01-20"},{"cvss_score":8.4,"headline":"Use after free in n/a","id":"CVE-2024-48423","kev_date_added":null,"published":"2024-10-24"},{"cvss_score":8.4,"headline":"Memory corruption in Assimp","id":"CVE-2024-45679","kev_date_added":null,"published":"2024-09-18"},{"cvss_score":8.4,"headline":"Memory corruption in Assimp","id":"CVE-2024-40724","kev_date_added":null,"published":"2024-07-19"},{"cvss_score":6.5,"headline":"Null dereference in n/a","id":"CVE-2022-38528","kev_date_added":null,"published":"2022-09-06"},{"cvss_score":6.2,"headline":"Memory corruption in n/a","id":"CVE-2024-53425","kev_date_added":null,"published":"2024-11-21"},{"cvss_score":6.2,"headline":"Memory corruption in n/a","id":"CVE-2024-48426","kev_date_added":null,"published":"2024-10-24"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-03-21","vendors":["Open Asset Import Library"]},"summary":"A heap-based buffer overflow in Assimp's CSMLoader allows remote attackers to execute arbitrary code or cause denial of service via crafted files.","url":"https://insights.sbomify.com/CVE-2025-2592/"}