CVE-2025-26042 Uptime Kuma's Regular Expression in pushdeeer and whapi file Leads to ReDoS Vulnerability Due to Catastrophic Backtracking
An attacker can cause a denial of service in Uptime Kuma by triggering catastrophic backtracking in a regular expression during notification creation.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2025-26042?
CVE-2025-26042 is a medium-severity denial of service vulnerability in n/a, published on 17 Mar 2025. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Official description
Uptime Kuma >== 1.23.0 has a ReDoS vulnerability, specifically when an administrator creates a notification through the web service. If a string is provided it triggers catastrophic backtracking in the regular expression, leading to a ReDoS attack.
Weakness: CWE-1333
Which versions are affected by CVE-2025-26042?
4 open source packages ship an affected version, including uptime-kuma.
| Package | Affected | Fixed in |
|---|---|---|
uptime-kuma npm | From 1.15.0 to 1.23.16 | None |
uptime-kuma npm | From 1.15.0 to 1.23.16 | None |
uptime-kuma npm | From 2.0.0-beta.0 | 2.0.0-beta.2 |
uptime-kuma npm | From 2.0.0-beta.0 | 2.0.0-beta.2 |
How do I fix CVE-2025-26042?
Upgrade uptime-kuma to 2.0.0-beta.2 or later.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2025-26042 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-26042 exists.
Sources
Also known as GHSA-hx7h-9vf7-5xhg.