# CVE-2025-26042: Uptime Kuma's Regular Expression in pushdeeer and whapi file Leads to ReDoS Vulnerability Due to Catastrophic Backtracking

> An attacker can cause a denial of service in Uptime Kuma by triggering catastrophic backtracking in a regular expression during notification creation.

- **Severity:** Medium 6.0 (`CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:U/C:L/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 17 Mar 2025
- **Updated:** 26 Jan 2026
- **Also known as:** GHSA-hx7h-9vf7-5xhg

## What is CVE-2025-26042?

CVE-2025-26042 is a medium-severity denial of service vulnerability in n/a, published on 17 Mar 2025. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

Uptime Kuma >== 1.23.0 has a ReDoS vulnerability, specifically when an administrator creates a notification through the web service. If a string is provided it triggers catastrophic backtracking in the regular expression, leading to a ReDoS attack.

Weakness: CWE-1333 (Inefficient Regular Expression Complexity)

## Which versions are affected by CVE-2025-26042?

4 open source packages ship an affected version, including uptime-kuma.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `uptime-kuma` | npm | From 1.15.0 to 1.23.16 | None |
| `uptime-kuma` | npm | From 1.15.0 to 1.23.16 | None |
| `uptime-kuma` | npm | From 2.0.0-beta.0 | 2.0.0-beta.2 |
| `uptime-kuma` | npm | From 2.0.0-beta.0 | 2.0.0-beta.2 |

## How do I fix CVE-2025-26042?

Upgrade uptime-kuma to 2.0.0-beta.2 or later.

## Is CVE-2025-26042 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-26042 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-26042 and fix it if it is affected.

What it is: CVE-2025-26042 is a medium-severity denial of service vulnerability in n/a, published on 17 Mar 2025. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-26042 exists.

Affected packages and fixed versions:
- uptime-kuma (npm): affected from 1.15.0 up to 1.23.16; no fix listed
- uptime-kuma (npm): affected from 1.15.0 up to 1.23.16; no fix listed
- uptime-kuma (npm): affected from 2.0.0-beta.0; fixed in 2.0.0-beta.2
- uptime-kuma (npm): affected from 2.0.0-beta.0; fixed in 2.0.0-beta.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-26042/ (Markdown: https://insights.sbomify.com/CVE-2025-26042/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-26042
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-26042
- OSV: https://osv.dev/vulnerability/CVE-2025-26042

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-26042/
Summaries are generated and may contain mistakes; the official description above is the record.
