# CVE-2025-26074: Conductor vulnerable to OS command injection through unrestricted access to Java classes

> Remote attackers can execute arbitrary OS commands in Orkes Conductor via unrestricted Java class access.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 Jun 2025
- **Updated:** 30 Jun 2025
- **Also known as:** GHSA-8gqp-hr9g-pg62

## What is CVE-2025-26074?

CVE-2025-26074 is a critical command injection vulnerability in n/a, published on 30 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Orkes Conductor v3.21.11 allows remote attackers to execute arbitrary OS commands through unrestricted access to Java classes.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2025-26074?

2 open source packages ship an affected version, including org.conductoross:conductor-core.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.conductoross:conductor-core` | Maven | All versions | 3.21.13 |
| `org.conductoross:conductor-core` | Maven | All versions | 3.21.13 |

## How do I fix CVE-2025-26074?

Upgrade org.conductoross:conductor-core to 3.21.13 or later.

## Is CVE-2025-26074 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-26074 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-26074 and fix it if it is affected.

What it is: CVE-2025-26074 is a critical command injection vulnerability in n/a, published on 30 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-26074 exists.

Affected packages and fixed versions:
- org.conductoross:conductor-core (Maven): affected all versions; fixed in 3.21.13
- org.conductoross:conductor-core (Maven): affected all versions; fixed in 3.21.13

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-26074/ (Markdown: https://insights.sbomify.com/CVE-2025-26074/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-26074
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-26074
- OSV: https://osv.dev/vulnerability/CVE-2025-26074

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-26074/
Summaries are generated and may contain mistakes; the official description above is the record.
