CVE-2025-2614 Allocation of Resources Without Limits or Throttling in GitLab

Medium 6.5 Published Updated

An authenticated user can cause a denial of service in GitLab by creating specially crafted content that consumes excessive server resources.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-2614?

CVE-2025-2614 is a medium-severity denial of service vulnerability in Gitlab Gitlab, published on 13 Aug 2025. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

An issue has been discovered in GitLab CE/EE affecting all versions from 11.6 before 18.0.6, 18.1 before 18.1.4, and 18.2 before 18.2.2 that could have allowed an authenticated user to cause a denial of service condition by creating specially crafted content that consumes excessive server resources when processed.

Weakness: CWE-770

Which versions are affected by CVE-2025-2614?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 11.6.018.0.6, 18.1.4, 18.2.2

Products include Gitlab Gitlab.

How do I fix CVE-2025-2614?

Upgrade gitlab to a fixed version for your release line: 18.0.6, 18.1.4 or 18.2.2.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2025-2614 being exploited?

There is no known exploitation of CVE-2025-2614 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2025-2614, GHSA-wxx2-2cv7-vhx6, MINI-j853-r33w-74w4, MINI-mv65-mwc6-6x4r, MINI-r499-27xj-p892, UBUNTU-CVE-2025-2614.

Is CVE-2025-2614 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free