CVE-2025-2615 Insertion of Sensitive Information Into Sent Data in GitLab
A blocked user can access sensitive information via GraphQL subscriptions over WebSocket connections in GitLab.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-2615?
CVE-2025-2615 is a medium-severity vulnerability in Gitlab Gitlab, published on 15 Nov 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
GitLab has remediated an issue in GitLab CE/EE affecting all versions from 16.7 before 18.3.6, 18.4 before 18.4.4, and 18.5 before 18.5.2, that could have allowed a blocked user to access sensitive information by establishing GraphQL subscriptions through WebSocket connections.
Weakness: CWE-201
Which versions are affected by CVE-2025-2615?
1 open source package ship an affected version, including gitlab. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
gitlab Bitnami | From 16.7.0 | 18.3.6, 18.4.4, 18.5.2 |
Products include Gitlab Gitlab.
How do I fix CVE-2025-2615?
Upgrade gitlab to a fixed version for your release line: 18.3.6, 18.4.4 or 18.5.2.
Is CVE-2025-2615 being exploited?
There is no known exploitation of CVE-2025-2615 in the wild and no public exploit code.
Other vulnerabilities in Gitlab Gitlab
- CVE-2026-97229 GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound
- CVE-2026-85706 GitLab Community Edition and Enterprise Edition Path Traversal
- CVE-2023-7028 GitLab Community and Enterprise Editions Improper Access Control
- CVE-2021-22205 GitLab Community and Enterprise Editions Remote Code Execution
- CVE-2021-39935 GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF)
Sources
Also known as BIT-gitlab-2025-2615, GHSA-rm4r-vwvw-vj67, MINI-29mm-r2vm-4g84, MINI-5gwf-fcv8-gm8w, MINI-5mh4-8hf3-p257, MINI-684m-h2qw-q9hx and 13 more.