# CVE-2025-26159: Laravel Starter Cross Site Scripting (XSS)

> Attackers with tag creation privileges can inject malicious JavaScript via the tag name field in Laravel Starter.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 22 Apr 2025
- **Updated:** 22 Apr 2025
- **Also known as:** GHSA-fpx3-h2pc-88vf

## What is CVE-2025-26159?

CVE-2025-26159 is a medium-severity cross-site scripting vulnerability in n/a, published on 22 Apr 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Laravel Starter 11.11.0 is vulnerable to Cross Site Scripting (XSS) in the tags feature. Any user with the ability of create or modify tags can inject malicious JavaScript code in the name field.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-26159?

2 open source packages ship an affected version, including nasirkhan/laravel-starter.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nasirkhan/laravel-starter` | Packagist | All versions | 11.11.0 |
| `nasirkhan/laravel-starter` | Packagist | All versions | 11.11.0 |

## How do I fix CVE-2025-26159?

Upgrade nasirkhan/laravel-starter to 11.11.0 or later.

## Is CVE-2025-26159 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-26159 exists.

Public exploit code:

- This script decodes, filters, and extracts cookies as part of the exploitation of CVE-2025-26159. (github_poc): https://github.com/godBADTRY/CVE-2025-26159

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-26159 and fix it if it is affected.

What it is: CVE-2025-26159 is a medium-severity cross-site scripting vulnerability in n/a, published on 22 Apr 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-26159 exists.

Affected packages and fixed versions:
- nasirkhan/laravel-starter (Packagist): affected all versions; fixed in 11.11.0
- nasirkhan/laravel-starter (Packagist): affected all versions; fixed in 11.11.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-26159/ (Markdown: https://insights.sbomify.com/CVE-2025-26159/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-26159
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-26159
- OSV: https://osv.dev/vulnerability/CVE-2025-26159

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-26159/
Summaries are generated and may contain mistakes; the official description above is the record.
