CVE-2025-26260 Plenti - Code Injection - Denial of Services

High 8.8 Published Updated

Attackers can execute arbitrary code by uploading maliciously named Svelte files via the postLocal endpoint in Plenti.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2025-26260?

CVE-2025-26260 is a high-severity code injection vulnerability in n/a, published on 12 Mar 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

Plenti <= 0.7.16 is vulnerable to code execution. Users uploading '.svelte' files with the /postLocal endpoint can define the file name as javascript codes. The server executes the uploaded file name in host, and cause code execution.

Weakness: CWE-94

Which versions are affected by CVE-2025-26260?

4 open source packages ship an affected version, including github.com/plentico/plenti. It affects 1 product.

PackageAffectedFixed in
github.com/plentico/plenti GoAll versionsNone
github.com/plentico/plenti GoAll versions0.7.17
github.com/plentico/plenti GoAll versions0.7.17
github.com/plentico/plenti GoAll versions0.7.17

Products include Plenti Plenti.

How do I fix CVE-2025-26260?

Upgrade github.com/plentico/plenti to 0.7.17 or later.

Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.

Is CVE-2025-26260 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-26260 exists.

Sources

Also known as GHSA-mj4v-hp69-27x5, GO-2025-3454, GO-2025-3515.

Is CVE-2025-26260 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free