CVE-2025-26269 Integer overflow in Dragonfly

Low 3.3 Published Updated

Authenticated users can crash the DragonflyDB daemon by passing a large negative integer to a Lua library command.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Local or same network only
Victim action needed
Not needed
Fix
None listed

What is CVE-2025-26269?

CVE-2025-26269 is a low-severity vulnerability in DragonflyDB Dragonfly, published on 17 Apr 2025. It can only be exploited from the same machine or local network, with no action from the victim.

Official description

DragonflyDB Dragonfly through 1.28.2 (fixed in 1.29.0) allows authenticated users to cause a denial of service (daemon crash) via a Lua library command that references a large negative integer.

Weakness: CWE-191

Which versions are affected by CVE-2025-26269?

It affects 1 product.

Products include Dragonflydb Dragonfly.

How do I fix CVE-2025-26269?

No fix has been published for CVE-2025-26269 yet. Limit exposure of the affected software until one is available.

Is CVE-2025-26269 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-26269 exists.

Sources

Also known as GHSA-cqc2-rc24-647j.

Is CVE-2025-26269 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free