{"answers":{"affected":"It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-26269 exists.","fix":"No fix has been published for CVE-2025-26269 yet. Limit exposure of the affected software until one is available.","what":"CVE-2025-26269 is a low-severity vulnerability in DragonflyDB Dragonfly, published on 17 Apr 2025. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-26269 and fix it if it is affected.\n\nWhat it is: CVE-2025-26269 is a low-severity vulnerability in DragonflyDB Dragonfly, published on 17 Apr 2025. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-26269 exists.\n\nAffected product: DragonflyDB Dragonfly. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-26269/ (Markdown: https://insights.sbomify.com/CVE-2025-26269/index.md)","id":"CVE-2025-26269","markdown":"https://insights.sbomify.com/CVE-2025-26269/index.md","name":"CVE-2025-26269","record":{"aliases":["GHSA-cqc2-rc24-647j"],"analysis":{"component_type":"database","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"DragonflyDB database","requires_auth":"low_privilege","summary":"Authenticated users can crash the DragonflyDB daemon by passing a large negative integer to a Lua library command.","user_interaction":"not_required","vuln_class":"integer_overflow"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"dragonfly","vendor":"dragonflydb"}],"cvss":{"score":3.3,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L","version":"3.1"},"cwes":[{"id":"CWE-191","name":"Integer Underflow (Wrap or Wraparound)"}],"description":"DragonflyDB Dragonfly through 1.28.2 (fixed in 1.29.0) allows authenticated users to cause a denial of service (daemon crash) via a Lua library command that references a large negative integer.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":false,"headline":"Integer overflow in Dragonfly","id":"CVE-2025-26269","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"integer_overflow","year":"2025"},"n_packages":0,"n_references":3,"next":{"headline":"dref is vulnerable to prototype pollution","id":"CVE-2025-26278"},"packages":[],"prev":{"headline":"Denial of service in Dragonfly","id":"CVE-2025-26268"},"products":["Dragonfly"],"published":"2025-04-17","related":[{"cvss_score":3.3,"headline":"Denial of service in Dragonfly","id":"CVE-2025-26268","kev_date_added":null,"published":"2025-04-17"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-23","vendors":["DragonflyDB"]},"summary":"Authenticated users can crash the DragonflyDB daemon by passing a large negative integer to a Lua library command.","url":"https://insights.sbomify.com/CVE-2025-26269/"}