# CVE-2025-26409: Access to Bootloader and Shell Over Serial Interface


- **Severity:** Medium 6.8 (`CVSS:3.1/AV:P/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** No
- **Published:** 11 Feb 2025
- **Updated:** 3 Nov 2025
- **Also known as:** GHSA-9cmp-ppm3-hp8w

## What is CVE-2025-26409?

CVE-2025-26409 is a medium-severity vulnerability in Wattsense Bridge, published on 11 Feb 2025. 

### Official description

A serial interface can be accessed with physical access to the PCB of Wattsense Bridge devices. After connecting to the interface, access to the bootloader is possible, as well as a Linux login prompt. The bootloader access can be used to gain a root shell on the device. This issue is fixed in recent firmware versions BSP >= 6.4.1.

Weakness: CWE-1299 (Missing Protection Mechanism for Alternate Hardware Interface), CWE-1191 (On-Chip Debug and Test Interface With Improper Access Control)

## Which versions are affected by CVE-2025-26409?


## How do I fix CVE-2025-26409?

No fix has been published for CVE-2025-26409 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-26409 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-26409 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-26409 and fix it if it is affected.

What it is: CVE-2025-26409 is a medium-severity vulnerability in Wattsense Bridge, published on 11 Feb 2025. 
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-26409 exists.

Affected product: Wattsense Bridge. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-26409/ (Markdown: https://insights.sbomify.com/CVE-2025-26409/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-26409
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-26409
- OSV: https://osv.dev/vulnerability/CVE-2025-26409

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-26409/
Summaries are generated and may contain mistakes; the official description above is the record.
