# CVE-2025-26413: Apache Kvrocks: The server was crashed by the negative offset


- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** No
- **Published:** 22 Apr 2025
- **Updated:** 12 May 2025
- **Also known as:** GHSA-6935-g2xg-qvf4

## What is CVE-2025-26413?

CVE-2025-26413 is a high-severity vulnerability in Apache Kvrocks, published on 22 Apr 2025. 

### Official description

Improper Input Validation vulnerability in Apache Kvrocks.

The SETRANGE command didn't check if the `offset` input is a positive integer and use it as an index
of a string. So it will cause the server to crash due to its index is  out of range.
This issue affects Apache Kvrocks: through 2.11.1.

Users are recommended to upgrade to version 2.12.0, which fixes the issue.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2025-26413?

It affects 1 product.


Products: Apache Kvrocks.

## How do I fix CVE-2025-26413?

No fix has been published for CVE-2025-26413 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-26413 being exploited?

There is no known exploitation of CVE-2025-26413 in the wild and no public exploit code.

## Other vulnerabilities in Apache Kvrocks

- [CVE-2025-25069](https://insights.sbomify.com/CVE-2025-25069/): Apache Kvrocks: Cross-Protocol Scripting Vulnerability (medium 6.5)
- [CVE-2025-59790](https://insights.sbomify.com/CVE-2025-59790/): Apache Kvrocks: RESET command grants admin privileges (medium 5.4)
- [CVE-2025-59792](https://insights.sbomify.com/CVE-2025-59792/): Apache Kvrocks: MONITOR command reveals plaintext credentials to non-admins (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-26413 and fix it if it is affected.

What it is: CVE-2025-26413 is a high-severity vulnerability in Apache Kvrocks, published on 22 Apr 2025. 
Exploitation: There is no known exploitation of CVE-2025-26413 in the wild and no public exploit code.

Affected product: Apache Kvrocks. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-26413/ (Markdown: https://insights.sbomify.com/CVE-2025-26413/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-26413
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-26413
- OSV: https://osv.dev/vulnerability/CVE-2025-26413

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-26413/
Summaries are generated and may contain mistakes; the official description above is the record.
