CVE-2025-26467 Apache Cassandra: User with MODIFY permission on ALL KEYSPACES can escalate privileges to superuser via unsafe actions (4.0.16 only)
Users with MODIFY permissions on all keyspaces can escalate to superuser privileges via unsafe actions in Apache Cassandra.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-26467?
CVE-2025-26467 is a high-severity vulnerability in Apache Cassandra, published on 25 Aug 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Privilege Defined With Unsafe Actions vulnerability in Apache Cassandra. An user with MODIFY permission ON ALL KEYSPACES can escalate privileges to superuser within a targeted Cassandra cluster via unsafe actions to a system resource. Operators granting data MODIFY permission on all keyspaces on affected versions should review data access rules for potential breaches.
This issue affects Apache Cassandra 3.0.30, 3.11.17, 4.0.16, 4.1.7, 5.0.2, but this advisory is only for 4.0.16 because the fix to CVE-2025-23015 was incorrectly applied to 4.0.16, so that version is still affected.
Users in the 4.0 series are recommended to upgrade to version 4.0.17 which fixes the issue. Users from 3.0, 3.11, 4.1 and 5.0 series should follow recommendation from CVE-2025-23015.
Weakness: CWE-267
Which versions are affected by CVE-2025-26467?
3 open source packages ship an affected version, including org.apache.cassandra:cassandra-all and cassandra. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.cassandra:cassandra-all Maven | From 4.0.16 | 4.0.17 |
org.apache.cassandra:cassandra-all Maven | From 4.0.16 | 4.0.17 |
cassandra Bitnami | From 4.0.16 | 4.0.17 |
Products include Apache Cassandra.
How do I fix CVE-2025-26467?
Upgrade org.apache.cassandra:cassandra-all to 4.0.17 or later.
Is CVE-2025-26467 being exploited?
There is no known exploitation of CVE-2025-26467 in the wild and no public exploit code.
Other vulnerabilities in Apache Cassandra
- CVE-2016-3427 Oracle Java SE and JRockit Unspecified
- CVE-2018-8016 Missing Authentication for Critical Function in Apache Cassandra
- CVE-2021-44521 Remote code execution for scripted UDFs
- CVE-2026-27314 Apache Cassandra: Privilege escalation via ADD IDENTITY authorization bypass
- CVE-2025-23015 Apache Cassandra: User with MODIFY permission on ALL KEYSPACES can escalate privileges to superuser via unsafe actions
Sources
Also known as AZL-66675, AZL-66698, BIT-cassandra-2025-26467, GHSA-5c4f-pxmx-xcm4, MINI-34w9-v8jh-6837, MINI-7w3x-5cr3-6598 and 1 more.