{"answers":{"affected":"3 open source packages ship an affected version, including org.apache.cassandra:cassandra-all and cassandra. It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-26467 in the wild and no public exploit code.","fix":"Upgrade org.apache.cassandra:cassandra-all to 4.0.17 or later.","what":"CVE-2025-26467 is a high-severity vulnerability in Apache Cassandra, published on 25 Aug 2025. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-26467 and fix it if it is affected.\n\nWhat it is: CVE-2025-26467 is a high-severity vulnerability in Apache Cassandra, published on 25 Aug 2025. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-26467 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.apache.cassandra:cassandra-all (Maven): affected from 4.0.16; fixed in 4.0.17\n- org.apache.cassandra:cassandra-all (Maven): affected from 4.0.16; fixed in 4.0.17\n- cassandra (Bitnami): affected from 4.0.16; fixed in 4.0.17\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-26467/ (Markdown: https://insights.sbomify.com/CVE-2025-26467/index.md)","id":"CVE-2025-26467","markdown":"https://insights.sbomify.com/CVE-2025-26467/index.md","name":"CVE-2025-26467","record":{"aliases":["AZL-66675","AZL-66698","BIT-cassandra-2025-26467","GHSA-5c4f-pxmx-xcm4","MINI-34w9-v8jh-6837","MINI-7w3x-5cr3-6598","MINI-jr64-3chw-9w3p"],"analysis":{"component_type":"database","fix_type":"upgrade","impacts":["privilege_escalation"],"network_reachable":"yes","non_default_config":false,"product_category":"Apache Cassandra","requires_auth":"low_privilege","summary":"Users with MODIFY permissions on all keyspaces can escalate to superuser privileges via unsafe actions in Apache Cassandra.","user_interaction":"not_required","vuln_class":"privilege_escalation"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"cassandra","vendor":"apache"}],"cvss":{"score":8.8,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-267","name":"Privilege Defined With Unsafe Actions"}],"description":"Privilege Defined With Unsafe Actions vulnerability in Apache Cassandra. An user with MODIFY permission ON ALL KEYSPACES can escalate privileges to superuser within a targeted Cassandra cluster via unsafe actions to a system resource. Operators granting data MODIFY permission on all keyspaces on affected versions should review data access rules for potential breaches.\n\nThis issue affects Apache Cassandra 3.0.30, 3.11.17, 4.0.16, 4.1.7, 5.0.2, but this advisory is only for 4.0.16 because the fix to CVE-2025-23015 was incorrectly applied to 4.0.16, so that version is still affected.\n\nUsers in the 4.0 series are recommended to upgrade to version 4.0.17 which fixes the issue. Users from 3.0, 3.11, 4.1 and 5.0 series should follow recommendation from CVE-2025-23015.","ecosystems":["Bitnami","Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apache Cassandra: User with MODIFY permission on ALL KEYSPACES can escalate privileges to superuser via unsafe actions (4.0.16 only)","id":"CVE-2025-26467","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"privilege_escalation","year":"2025"},"n_packages":3,"n_references":1,"next":{"headline":"CyberData 011209 SIP Emergency Intercom Missing Authentication for Critical Function","id":"CVE-2025-26468"},"packages":[{"ecosystem":"Bitnami","fixed":["4.0.17"],"introduced":["4.0.16"],"last_affected":[],"package":"cassandra","purl":"pkg:bitnami/cassandra","source":"BIT-cassandra-2025-26467"},{"ecosystem":"Maven","fixed":["4.0.17"],"introduced":["4.0.16"],"last_affected":[],"package":"org.apache.cassandra:cassandra-all","purl":null,"source":"GHSA-5c4f-pxmx-xcm4"},{"ecosystem":"Maven","fixed":["4.0.17"],"introduced":["4.0.16"],"last_affected":[],"package":"org.apache.cassandra:cassandra-all","purl":"pkg:maven/org.apache.cassandra/cassandra-all","source":"GHSA-5c4f-pxmx-xcm4"}],"prev":{"headline":"Openssh: denial-of-service in openssh","id":"CVE-2025-26466"},"products":["Apache Cassandra"],"published":"2025-08-25","related":[{"cvss_score":9.8,"headline":"Oracle Java SE and JRockit Unspecified","id":"CVE-2016-3427","kev_date_added":"2023-05-12","published":"2016-04-21"},{"cvss_score":9.8,"headline":"Missing Authentication for Critical Function in Apache Cassandra","id":"CVE-2018-8016","kev_date_added":null,"published":"2018-06-28"},{"cvss_score":9.1,"headline":"Remote code execution for scripted UDFs","id":"CVE-2021-44521","kev_date_added":null,"published":"2022-02-11"},{"cvss_score":8.8,"headline":"Apache Cassandra: Privilege escalation via ADD IDENTITY authorization bypass","id":"CVE-2026-27314","kev_date_added":null,"published":"2026-04-07"},{"cvss_score":8.8,"headline":"Apache Cassandra: User with MODIFY permission on ALL KEYSPACES can escalate privileges to superuser via unsafe actions","id":"CVE-2025-23015","kev_date_added":null,"published":"2025-02-04"},{"cvss_score":7.8,"headline":"Apache Cassandra: Privilege escalation when enabling FQL/Audit logs","id":"CVE-2023-30601","kev_date_added":null,"published":"2023-05-30"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-02-26","vendors":["Apache Software Foundation"]},"summary":"Users with MODIFY permissions on all keyspaces can escalate to superuser privileges via unsafe actions in Apache Cassandra.","url":"https://insights.sbomify.com/CVE-2025-26467/"}